#1 22.01.2014 07:57:03

LabelZero
Administrator
Зарегистрирован: 08.10.2010
Сообщений: 56
IP-адрес

Странное сообщение в MATE

Здравствуйте, хотел настроить автомонтирование в MATE, собрал его из портов и при тычке на пункт в меню "Переход" на мой виндовый раздел в ntfs с фильмами под рутом увидел сообщение в окне ошибке монтирования, что mount не принимает параметр "--m"(mount: illegal option --m), под пользователем сообщения не было, но и монтирования тоже, позже в policykit.conf разрешил все пользователю- сообщение стало и под ним.
Флаги оптимизации не использовал в этот раз(собрано встроенным clang 3.3), с ними было тоже, FreeBSD версии 10.0 Release. В rc.conf стоит запуск hal, dbus, polkit, devd, fusefs(ntfs- драйвер стоит). MATE 1.6.1 из новых портов.
Как это исправить?

#2 22.01.2014 08:02:35

redix
Administrator
Зарегистрирован: 04.04.2013
Сообщений: 4 750
IP-адрес

Странное сообщение в MATE

LabelZero, ghostBSD использует mate-desktop. Может у них найдется что то полезное. http://ghostbsd.org/

#3 22.01.2014 08:09:27

LabelZero
Administrator
Зарегистрирован: 08.10.2010
Сообщений: 56
IP-адрес

Странное сообщение в MATE

А вот сообщение от KDE4:

An error occurred while accessing 'Жёсткий диск (840,8 ГиБ)', the system responded: org.freedesktop.Hal.Device.Volume.UnknownFailure: mount: illegal option -- u usage: mount [-t fstype] [-o options] target_fs mount_point


Будто обе неправильно используют mount.

Кстати, ntfs-3g справлялся без проблем, скрипт написал, монтировалось по скрипту при загрузке, но это не нравилось KDE и MATE.

#4 22.01.2014 08:36:21

yars
Administrator
Зарегистрирован: 23.03.2012
Сообщений: 9 369
IP-адрес

Странное сообщение в MATE

Quote by LabelZero
"(mount: illegal option --m)

Это у gvfs такой есть -

  -m, --mountable                Подключить как подключаемый

Board footer