#1 11.09.2014 16:57:21

1000Mhz
Administrator
Зарегистрирован: 17.08.2014
Сообщений: 816
IP-адрес

Нет звука при редактировании видео

или screen record.
PA нет, ALSA.
Avidemux - там только OSS например.

Пересобирать чтоле?

#2 11.09.2014 17:51:15

yars
Administrator
Зарегистрирован: 23.03.2012
Сообщений: 9 369
IP-адрес

Нет звука при редактировании видео

А alsa-oss compatibility modules на что?

#3 11.09.2014 18:14:18

1000Mhz
Administrator
Зарегистрирован: 17.08.2014
Сообщений: 816
IP-адрес

Нет звука при редактировании видео

yars, ну вот так:

rpm -qa | grep -i alsa-oss
alsa-oss-1.0.25-8.4.1.i586

По дефолту звука нет. Надо чет сделать, но я не знаю пока, чего :)

#4 11.09.2014 18:20:19

mozgfx
Administrator
Зарегистрирован: 29.09.2012
Сообщений: 1 614
IP-адрес

Нет звука при редактировании видео

1000 раз говорил не являясь дрессировщиком не лезть в зоопарк звуковых систем...
Чем Вам пульса мешает?
С экрана запись в openSUSE в GUI режиме полноценно получается только с помощью vokoscreen (все другие в моем случае пишут неполноценно коверкают видео и звук не совпадает по времени).
Либо с помощью консоли ffmpeg.
Для редактирования видео советую попробовать kdenlive.

#5 11.09.2014 18:29:13

1000Mhz
Administrator
Зарегистрирован: 17.08.2014
Сообщений: 816
IP-адрес

Нет звука при редактировании видео

mozgfx, ну я при установке выбрал ALSA вместо PA, вы же знаете, там полная свобода выбора))
Ясно, что могут быть проблемы, но получается, что из Пакмана жесткая привязка к PA? Проведу тесты.

#6 12.09.2014 05:54:13

mozgfx
Administrator
Зарегистрирован: 29.09.2012
Сообщений: 1 614
IP-адрес

Нет звука при редактировании видео

Вы лучше расскажите какая цель в Вашем случае преследуется? (я про отключение PA)

Quote by 1000Mhz
но получается, что из Пакмана жесткая привязка к PA?

Как правило все пакеты хорошо совместимы с дистрибутивом, а он из коробки по умолчанию поддерживает PA.
Как-то попытался отключить в настройках, но так как не удалось заставить некоторые программы воспроизводить звук, вернул всё на место.
Проблем со звуком не возникало, даже при работе в ресурсоемких звуковых редакторах работающих в Wine.
Поэтому не вижу смысла выключать PA.

#7 12.09.2014 06:44:34

yars
Administrator
Зарегистрирован: 23.03.2012
Сообщений: 9 369
IP-адрес

Нет звука при редактировании видео

Надо чет сделать, но я не знаю пока, чего :)

Вероятно,
# systemctl enable alsa-oss.service
# systemctl start alsa-oss.service

У меня, по крайней мере, эти модули могут подгружаться отдельным init-скриптом, rc.alsa-oss, но в работе я их не проверял, так как не имею ПО, завязанного на OSS.

#8 29.09.2014 19:25:00

1000Mhz
Administrator
Зарегистрирован: 17.08.2014
Сообщений: 816
IP-адрес

Нет звука при редактировании видео

Quote by mozgfx
Поэтому не вижу смысла выключать PA.

Не вижу смысла включать :D Avidemux, в сохраненном файле все нормально.

Board footer