#1 03.02.2015 09:54:59

MadChem
Administrator
Зарегистрирован: 02.02.2015
Сообщений: 6
IP-адрес

Проблема запуска ОС

Эксплуатировал Зюзю два месяца, после чего какой-то черт дернул меня купить новый хард для испытания других дистров. В итоге после установки не запустилась ни слака, ни зюзя, хотя они были на разных дисках.
LiLo пытался загрузить слаку, но безуспешно. Груб вообще не появлялся. Переустановка ничего не дала. Запустил из под Slax, проверил диск:
[console]root@slax:~# fdisk -l

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x000c8f91

Device Boot Start End Blocks Id System
/dev/sda1 63 199993184 99996561 83 Linux
Partition 1 does not start on physical sector boundary.
/dev/sda2 199993185 453482819 126744817+ 5 Extended
Partition 2 does not start on physical sector boundary.
/dev/sda3 * 453484544 537374719 41945088 83 Linux
/dev/sda4 537374720 976773119 219699200 83 Linux
/dev/sda5 199993248 201487229 746991 82 Linux swap
/dev/sda6 201487293 261490004 30001356 83 Linux
Partition 6 does not start on physical sector boundary.
/dev/sda7 261490068 453482819 95996376 83 Linux
Partition 7 does not start on physical sector boundary.

Disk /dev/sdb: 8084 MB, 8084590080 bytes
255 heads, 63 sectors/track, 982 cylinders, total 15790215 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x04dd5721

Device Boot Start End Blocks Id System
/dev/sdb1 * 63 15775829 7887883+ b W95 FAT32[/console]
На втором винте было то же самое, но только один расширенный раздел для SUSE.
Помогите, пожалуйста! В линуксе новичок, с компьютером только на "Вы", если кто-то откликнется - снабдите, пожалуйста, ответы парой ссылок на вики - я плохо знаю что как работает. На винду возвращаться не хочу :'(

// внимательнее используйте BB-коды, исправил разметку.
Rizado

#2 03.02.2015 10:26:08

1000Mhz
Administrator
Зарегистрирован: 17.08.2014
Сообщений: 816
IP-адрес

Проблема запуска ОС

Ну и зоопарк)) Я бы порекомендовал переразбить диски так, чтобы все ОС были на одном, swap-раздел общий. В таком варианте проблем быть не должно.

#3 03.02.2015 10:29:49

diablopc
Administrator
Зарегистрирован: 17.09.2014
Сообщений: 1 032
IP-адрес

Проблема запуска ОС

1000Mhz, или второй вариант: каждую систему на отдельный диск, при этом с отключенным вторым, а потом просто в конфиги граба\лило добавить нужный пункт....

#4 03.02.2015 10:35:07

1000Mhz
Administrator
Зарегистрирован: 17.08.2014
Сообщений: 816
IP-адрес

Проблема запуска ОС

diablopc, думаю, что лучше все-таки следовать принципу "данные- отдельно, система- отдельно". У меня именно такая конфигурация: маленький SSD для ОС (правда, она всего одна, но это неважно), и большой HDD под "файлопомойку".

#5 03.02.2015 10:37:50

diablopc
Administrator
Зарегистрирован: 17.09.2014
Сообщений: 1 032
IP-адрес

Проблема запуска ОС

1000Mhz, ну я по своему конфигу дал вариант...
один винт с основной системой, второй с тестовой, третий - файлопомойка)
ЗЫ
я ставлю именно так как написал выше..

#6 03.02.2015 11:00:05

diablopc
Administrator
Зарегистрирован: 17.09.2014
Сообщений: 1 032
IP-адрес

Проблема запуска ОС

//флудим здесь: http://linuxforum.ru/viewtopic.php?id=37570

#7 03.02.2015 12:27:36

MadChem
Administrator
Зарегистрирован: 02.02.2015
Сообщений: 6
IP-адрес

Проблема запуска ОС

Понятно что зоопарк, но загрузчик вообще не стартует. Это из-за разбитых секторов?

#8 03.02.2015 12:33:38

diablopc
Administrator
Зарегистрирован: 17.09.2014
Сообщений: 1 032
IP-адрес

Проблема запуска ОС

Quote by MadChem
Понятно что зоопарк, но загрузчик вообще не стартует. Это из-за разбитых секторов?
Ну тут трудно что-то сказать, так как кроме вас никто не знает как, куда и с какими параметрами вы ставили загрузчики, а соответственно кто из них и кого потер тоже непонятно....
...если сохранность системы не критична то я соглашусь с этим:
Quote by 1000Mhz
Я бы порекомендовал переразбить диски

Ну а как делать, или обе системы на один диск, или по отдельности - это уже вам решать...
...если по отдельности - то ИМХО лучше всего ставить с отключением дисков)

#9 04.02.2015 09:33:18

MadChem
Administrator
Зарегистрирован: 02.02.2015
Сообщений: 6
IP-адрес

Проблема запуска ОС

С одним винтом разобрался варварским методом: нашел программу низкоуровнего форматирования и обнулил его. Установка SUSE прошла успешно, перезагрузился и теперь даже стабильно работает. Теперь такая картинка:
[console]Disk /dev/sda: 931,5 GiB, 1000204886016 bytes, 1953525168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0x00046c6a

Device Boot Start End Sectors Size Id Type
/dev/sda1 2048 4208639 4206592 2G 82 Linux swap / Solaris
/dev/sda2 * 4208640 88100863 83892224 40G 83 Linux
/dev/sda3 88100864 1953523711 1865422848 889,5G 83 Linux
[/console]
Всем спасибо за советы и поддержку!

#10 04.02.2015 09:37:19

diablopc
Administrator
Зарегистрирован: 17.09.2014
Сообщений: 1 032
IP-адрес

Проблема запуска ОС

Quote by MadChem
нашел программу низкоуровнего форматирования

Это действительно
Quote by MadChem
варварским методом
ЗЫ
А что со вторым??

#11 04.02.2015 10:22:35

MadChem
Administrator
Зарегистрирован: 02.02.2015
Сообщений: 6
IP-адрес

Проблема запуска ОС


А что со вторым??

Второй пока не знаю - там САТА-шка контачит с переменным успехом. Сделаю - отпишусь.

#12 04.02.2015 10:57:59

yars
Administrator
Зарегистрирован: 23.03.2012
Сообщений: 9 369
IP-адрес

Проблема запуска ОС

Можно было и не трогать диск, а загрузиться с установочного носителя Slackware, после загрузки, в строке приглашения (boot:) набрать

hugesmp.s 3 root=/dev/sda1 rdinit= ro

и нажать Enter. Это только пример, реальное расположение корня вам виднее. После загрузки выполнить от рута
# lilo

На этом все, загрузчик восстановлен.
Установка других загрузчиков не требуется, остальные ОС вносятся в меню загрузки основной системы путем правки lilo.conf с последующим вызовом lilo от рута. Если вы не хотите lilo, ставьте grub, благо начиная с версии 14.1 он входит в дистрибутив. В этом случае, после загрузки с носителя Slackware, вам необходимо выполнить
# grub-mkconfig -o /boot/grub2/grub2.cfg
# grub-install /dev/sda

Quote by MadChem
нашел программу низкоуровнего форматирования

Больше не ищите, есть dd.

#13 06.02.2015 14:57:44

MadChem
Administrator
Зарегистрирован: 02.02.2015
Сообщений: 6
IP-адрес

Проблема запуска ОС

Quote by yars
Больше не ищите, есть dd.

Обнулил диск dd, попытался установить Федору. Федора встала, после перезагрузки та же песня: черный экран, моргает _ и все. Slackware дает тоже самое.
Quote by yars
после загрузки, в строке приглашения (boot:) набрать

Система не загружается, моргают кнопки Caps Lock и Scroll Lock, на ctrl+alt+del не откликается.
Установил XP с другого компьютера, все загрузилось. Однако, с моего компа загрузка оканчивается классическим виндусовским синим экраном с пометкой "the BIOS in this system is not fully ACPI comliant" и советом обновить БИОС. Материнка ASUS H97-Plus, нашел обновление для EFI с 2103 до 2306. Толку никакого. Я так понял, что проблема в железе, а не софте.
Диск Toshiba DT01ACA050 500Gb, Cache 32Mb.
ЗЫ: Seagate Barracuda ST1000DM003 1Tb, Cache64Mb работает нормально.

#14 06.02.2015 15:05:22

1000Mhz
Administrator
Зарегистрирован: 17.08.2014
Сообщений: 816
IP-адрес

Проблема запуска ОС

Ставьте на виртуалку.

#15 06.02.2015 16:09:49

mvt
Administrator
Зарегистрирован: 20.02.2010
Сообщений: 6 467
IP-адрес

Проблема запуска ОС

Quote by yars
Больше не ищите, есть dd.

Обнулил диск dd, попытался установить Федору. Федора встала, после перезагрузки та же песня: черный экран, моргает _ и все. Slackware дает тоже самое.
Quote by yars
после загрузки, в строке приглашения (boot:) набрать

Система не загружается, моргают кнопки Caps Lock и Scroll Lock, на ctrl+alt+del не откликается.
Установил XP с другого компьютера, все загрузилось. Однако, с моего компа загрузка оканчивается классическим виндусовским синим экраном с пометкой "the BIOS in this system is not fully ACPI comliant" и советом обновить БИОС. Материнка ASUS H97-Plus, нашел обновление для EFI с 2103 до 2306. Толку никакого. Я так понял, что проблема в железе, а не софте.
Диск Toshiba DT01ACA050 500Gb, Cache 32Mb.
ЗЫ: Seagate Barracuda ST1000DM003 1Tb, Cache64Mb работает нормально.

Разберитесь с разделами. Просто http://gparted.org/livecd.php / С него просто грузитесь и смотрите - что и как. Создайте (один раз! :) ) логичную структуру разделов на всех физических дисках, проверьте наличие флага boot, сделайте запасные разделы "для экспериментов" :) Swap - один на весь комп.
PS На вкус и цвет... Я пользуюсь grub 0.97, как основным загрузчиком всего компа. Он стоит в MBR, а его файлы - лежат далеко-далеко от всех систем. На разделе с инфой. И, до лампочки, что Вы там с системами делаете. А вот не ломается уже много лет, несмотря на "смелые эксперименты" :)
PPS Остальные загрузчики - я ставлю "на свой раздел", и просто в основном дописываю строчки загрузки других машинок. Или передача загрузки по цепочке типа

title PCLinuxOS
rootnoverify (hd1,1)
chainloader +1

Либо, как умная маша, прописываю ядро и initrd. Типа

title Runtu
root (hd1,11)
kernel /vmlinuz root=/dev/sda12 ro
initrd /initrd.img

#16 06.02.2015 18:36:37

yars
Administrator
Зарегистрирован: 23.03.2012
Сообщений: 9 369
IP-адрес

Проблема запуска ОС

Quote by MadChem
Система не загружается, моргают кнопки Caps Lock и Scroll Lock, на ctrl+alt+del не откликается.

Это называется «паника ядра». Вероятно, некорректно указываете корневой раздел, это распространенная ошибка новичков, пытающихся запустить систему с LiveCD или дистрибутивного носителя. Чтобы не гадать, приложите читаемое фото экрана с ошибкой.
Quote by MadChem
"the BIOS in this system is not fully ACPI comliant"

Достаточно в BIOS отключить ACPI, чтобы винда начала так думать. А в Linux можно сказать ядру acpi=off в случае реальных проблем с ACPI.

#17 07.02.2015 09:39:48

1000Mhz
Administrator
Зарегистрирован: 17.08.2014
Сообщений: 816
IP-адрес

Проблема запуска ОС

Quote by mvt
Я, как понял, он - "с нуля" хочет сделать комп, предусмотреть (заранее!) места под системы и инфу.

Quote by MadChem
после чего какой-то черт дернул меня купить новый хард для испытания других дистров.

- чел просто страдает фигней. "Испытания других дистров", но при этом даже не удосужился изучить базовые механизмы загрузки Linux.. испытатель, чо!))

#18 07.02.2015 21:41:25

MadChem
Administrator
Зарегистрирован: 02.02.2015
Сообщений: 6
IP-адрес

Проблема запуска ОС

Однако, чудесным "тыканием" в БИОСе, второй хард завелся и отлично работает *OK* Спасибо за совет, похоже, это действительно была kernel panic.
PS: на виртуалке не так интересно, как наживую.

#19 07.02.2015 23:16:59

ism
Administrator
Зарегистрирован: 08.03.2010
Сообщений: 79
IP-адрес

Проблема запуска ОС

Если диски монтируются не по UUID, то при перестановке дисков по SATA портам ничего не загрузится, так как в /dev диски будут под другими адресами
http://linuxguru.ru/administration/kak-posmotret-uuid-ustrojstv/

Board footer