#1 02.03.2015 19:47:05

akademon
Administrator
Зарегистрирован: 23.02.2010
Сообщений: 45
IP-адрес

Realtek ALC1150 нет звука

линукс минт 17.1 свежая установка
отсутсвует звук
звуковуха встроенная в материнку H97-D3H: Realtek ALC1150 115dB SNR HD Audio with built-in rear audio amplifier
взято с сайта производителя (http://www.gigabyte.com/products/product-page.aspx?pid=4962&kw=H97-D3H#ov)
обыкновенные колонки подключенны стандартно, сзади компа вход зеленого цвета. в вин7 все работает.
"Настройки-звук" есть 3 пункта:
1)
HDMI/Displayport 2
это звук через видяху на колонки встроенные в монитор, здесь звук работает, но нужен звук в обычных колонках.
2)
Digital Output (S/PDIF)
проверка звука не дает никаких результатов
3)
Analog Output
при проверке звука есть какие то звенящие звуки.

вывод команды sudo lspci -k | grep -i -A2 "multimedia\|audio"

00:1b.0 Audio device: Intel Corporation Device 8ca0
Subsystem: Gigabyte Technology Co., Ltd Device a182
Kernel driver in use: snd_hda_intel
--
01:00.1 Audio device: NVIDIA Corporation GF116 High Definition Audio Controller (rev a1)
Subsystem: Micro-Star International Co., Ltd. [MSI] Device 2610
Kernel driver in use: snd_hda_intel


куда копать чтобы звук появился?

#2 02.03.2015 20:02:40

akademon
Administrator
Зарегистрирован: 23.02.2010
Сообщений: 45
IP-адрес

Realtek ALC1150 нет звука

нашел решение.. был слегка удивлен, но помогло:
сделать нужно следующее:
sudo apt-get install alsa-tools

sudo hda-verb /dev/snd/hwC0D2 0x20 SET_COEF_INDEX 0x07
получаем такой вывод:
nid = 0x20, verb = 0x500, param = 0x7
value = 0x0

sudo hda-verb /dev/snd/hwC0D2 0x20 SET_PROC_COEF 0x7cb0
получаем такой вывод:
nid = 0x20, verb = 0x400, param = 0x7cb0
value = 0x0
решение нашел здесь: (http://habrahabr.ru/post/242253/)

Board footer