1

Тема: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

Для openSUSE 13.2:

Подключение репозиториев:

Консоль: root
[root@linuxforum.ru ~]# zypper ar -f http://packman.inode.at/suse/openSUSE_13.2/ packman && zypper ar -f http://opensuse-guide.org/repo/13.2/ libdvdcss2 && zypper mr -p 97 packman libdvdcss2 && zypper ref && zypper dup --from=packman

Установка кодеков: (одна большая команда)
Консоль: root
[root@linuxforum.ru ~]# zypper in gstreamer-0_10 gstreamer-0_10-plugins-ffmpeg gstreamer-0_10-plugins-base gstreamer-0_10-plugins-bad gstreamer-0_10-plugins-bad-orig-addon gstreamer-0_10-plugins-good gstreamer-0_10-plugins-good-extra gstreamer-0_10-plugins-ugly gstreamer-0_10-plugins-ugly-orig-addon faad2 libfaad2 a52dec x264_tMod lame twolame libxine2-codecs ffmpeg w32codec-all libavcodec52 libavcodec55 MPlayer faac libmpg123-0 libquicktime0 libxvidcore4 libmad0 libmad0-32bit libmpeg2-0 libmac2 mpeg2dec xvidcore libdcaenc0 dirac libdirac_encoder0 libdirac_decoder0 gstreamer gstreamer-plugins-bad gstreamer-plugins-base gstreamer-plugins-good gstreamer-plugins-ugly gstreamer-plugins-ugly-orig-addon gstreamer-plugins-bad-orig-addon gstreamer-plugins-libav gstreamer-plugins-good-extra libdvdread3 libdvdplay0 libdvdnav4 libdvdcss2 libavdevice52 libavdevice55 libavfilter1 libavfilter4 libavformat52 libavresample1 libavutil50 libavutil52 libmatroska6 libx264-142 libx264-142-32bit libvpx1 libswfdec0_9_2 libx265-32 x265 libvo-aacenc0 libx265-32-32bit

Так же после выполнения команды выше можно полностью обновиться:
Консоль: root
[root@linuxforum.ru ~]# zypper dup

MozgFx:Для ленивых сделал установку в 1 клик(только для 13.2):

Переходим по ссылке и жмем на "codecs-kde.ymp"

openSUSE 13.2 Установка кодеков в один клик

(сайт по ссылке в разработке там только это в данный момент готово)



Для openSUSE 13.1:

+ открыть спойлер

Подключение репозиториев:

Консоль: root
[root@linuxforum.ru ~]# zypper ar -f http://packman.inode.at/suse/openSUSE_13.1/ packman && zypper ar -f http://opensuse-guide.org/repo/13.1/ libdvdcss2 && zypper mr -p 97 packman libdvdcss2 && zypper ref && zypper dup --from=packman

Установка кодеков: (одна большая команда)
Консоль: root
[root@linuxforum.ru ~]# zypper in gstreamer-0_10 gstreamer-0_10-plugins-ffmpeg gstreamer-0_10-plugins-base gstreamer-0_10-plugins-bad gstreamer-0_10-plugins-bad-orig-addon gstreamer-0_10-plugins-good gstreamer-0_10-plugins-good-extra gstreamer-0_10-plugins-ugly gstreamer-0_10-plugins-ugly-orig-addon faad2 libfaad2 a52dec x264 lame twolame libxine2-codecs ffmpeg w32codec-all libavcodec52 libavcodec54 MPlayer faac libmpg123-0 libquicktime0 libxvidcore4 libmad0 libmad0-32bit libmpeg2-0 libmac2 mpeg2dec xvidcore libdcaenc0 dirac libdirac_encoder0 libdirac_decoder0 gstreamer gstreamer-plugins-bad gstreamer-plugins-base gstreamer-plugins-good gstreamer-plugins-ugly gstreamer-plugins-ugly-orig-addon gstreamer-plugins-bad-orig-addon gstreamer-plugins-libav gstreamer-plugins-good-extra libdvdread3 libdvdplay0 libdvdnav4 libdvdcss2 libavcodec55 libavdevice52 libavdevice54 libavdevice55 libavfilter1 libavfilter2 libavfilter3 libavformat52 libavformat54 libavresample0 libavresample1 libavutil50 libavutil51 libmatroska6 libx264-142 libx264-142-32bit libvpx1 libswfdec0_9_2 libx265-10 x265 libvo-aacenc0

Так же после выполнения команды выше можно полностью обновиться:
Консоль: root
[root@linuxforum.ru ~]# zypper dup

2

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

Такая большая портянка в скрипт просится. ab
Кстати, лично у меня тут просится расшифровка каждого устанавливаемого пакета (что, зачем, почему). Ну так, придирки, если честно.

3

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

basileus пишет

расшифровка каждого устанавливаемого пакета (что, зачем, почему)

pkgs.org знает это.

4

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

basileus пишет

Такая большая портянка в скрипт просится. ab

А зачем усложнять?

Простой копипастой ставить же.



з.ы. предложения по добавлению/удалению контента принимаются.

5

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

redix пишет

pkgs.org знает это.

Или http://software.opensuse.org/search

6

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

redix пишет

pkgs.org знает это.

Это понятно. Я же говорю, это придирки. По большому счёту тут этот скрипт вообще можно расписать на небольшую статью ("Коротенько, минут на 40" Тов. Огурцов) ad А потом выложить на вики. И отсылать туда. А ссылку на вики с соответствующими путями, где лежат пакеты для актуальной версии, вставить в основную ветку с решениями и советами. ab

7

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

Снова проблемы с mp4a (aac):

+ открыть спойлер

Консоль
zypper se -si faad gstreamer
Загрузка данных о репозиториях...
Чтение установленных пакетов...

С | Имя                                         | Тип   | Версия         | Архитектура | Репозиторий   
--+---------------------------------------------+-------+----------------+-------------+----------------
i | faad2                                       | пакет | 2.7-13.1       | x86_64      | pacman         
i | gstreamer                                   | пакет | 1.2.1-3.1      | x86_64      | pacman         
i | gstreamer-0_10                              | пакет | 0.10.36-14.12  | x86_64      | pacman         
i | gstreamer-0_10-plugin-esd                   | пакет | 0.10.31-16.1   | x86_64      | pacman         
i | gstreamer-0_10-plugins-bad                  | пакет | 0.10.23-24.3   | x86_64      | pacman         
i | gstreamer-0_10-plugins-bad-orig-addon       | пакет | 0.10.23-24.3   | x86_64      | pacman         
i | gstreamer-0_10-plugins-bad-orig-addon-32bit | пакет | 0.10.23-24.3   | x86_64      | pacman         
i | gstreamer-0_10-plugins-base                 | пакет | 0.10.36-12.21  | x86_64      | pacman         
i | gstreamer-0_10-plugins-ffmpeg               | пакет | 0.10.13-2000.1 | x86_64      | pacman         
i | gstreamer-0_10-plugins-ffmpeg-32bit         | пакет | 0.10.13-2000.1 | x86_64      | pacman         
i | gstreamer-0_10-plugins-fluendo_mp3          | пакет | 0.10.18-3.1    | x86_64      | pacman         
i | gstreamer-0_10-plugins-good                 | пакет | 0.10.31-16.1   | x86_64      | pacman         
i | gstreamer-0_10-plugins-good-extra           | пакет | 0.10.31-16.1   | x86_64      | pacman         
i | gstreamer-0_10-plugins-qt                   | пакет | 0.10.3-1.1     | x86_64      | openSUSE-Oss   
i | gstreamer-0_10-plugins-ugly                 | пакет | 0.10.19-12.1   | x86_64      | pacman         
i | gstreamer-0_10-plugins-ugly-32bit           | пакет | 0.10.19-12.1   | x86_64      | pacman         
i | gstreamer-0_10-plugins-ugly-orig-addon      | пакет | 0.10.19-12.1   | x86_64      | pacman         
i | gstreamer-plugins-base                      | пакет | 1.2.1-2.2      | x86_64      | pacman         
i | gstreamer-plugins-good                      | пакет | 1.2.1-2.1      | x86_64      | pacman         
i | gstreamer-plugins-good-extra                | пакет | 1.2.1-2.1      | x86_64      | pacman         
i | gstreamer-plugins-libav                     | пакет | 1.2.0-2.1      | x86_64      | pacman         
i | gstreamer-plugins-ugly                      | пакет | 1.2.1-2.1      | x86_64      | pacman         
i | gstreamer-plugins-ugly-orig-addon           | пакет | 1.2.1-2.1      | x86_64      | pacman         
i | libQtGStreamer-0_10-0                       | пакет | 0.10.3-1.1     | x86_64      | openSUSE-Oss   
i | libfaad2                                    | пакет | 2.7-13.1       | x86_64      | pacman         
i | libfaad2-32bit                              | пакет | 2.7-13.1       | x86_64      | pacman         
i | libgstreamer-0_10-0                         | пакет | 0.10.36-14.12  | x86_64      | pacman         
i | libgstreamer-0_10-0-32bit                   | пакет | 0.10.36-14.12  | x86_64      | pacman         
i | libgstreamer-1_0-0                          | пакет | 1.2.1-3.1      | x86_64      | pacman         
i | phonon-backend-gstreamer-0_10               | пакет | 4.7.0-2.4.1    | x86_64      | Update-openSUSE

Ну не хочет заводиться, хоть ты тресни!

8

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

aliaksei1818 пишет

Ну не хочет заводиться, хоть ты тресни!

На каком плеере?

zypper lr -up

9

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

Amarok, один только vlc молодец  - все кодеки в одном пакете, установил и забыл.

+ открыть спойлер

Консоль
zypper lr -upP
#  | Псевдоним                 | Имя                   | Включён | Обновление | Приоритет | URI                                                                                             
---+---------------------------+-----------------------+---------+------------+-----------+-------------------------------------------------------------------------------------------------
3 | Overman79_Factory         | Overman79_Factory     | Нет     | Нет        |   79      | http://download.opensuse.org/repositori … E_Factory/             
13 | home:Overman79            | home:Overman79        | Нет     | Нет        |   79      | http://download.opensuse.org/repositori … SUSE_13.1/               
16 | nVidia/latest             | nVidia/latest         | Нет     | Нет        |   79      | http://download.opensuse.org/repositori … SUSE_13.1/
1 | Enlightenment/Nightly     | Enlightenment/Factory | Нет     | Нет        |   89      | http://download.opensuse.org/repositori … SUSE_13.1/           
6 | UpdatedAppsKDE            | UpdatedAppsKDE        | Нет     | Нет        |   89      | ftp://ftp.mgts.by/pub/opensuse/reposito … SUSE_12.3/                   
7 | XOrg                      | XOrg                  | Нет     | Нет        |   89      | http://download.opensuse.org/repositori … SUSE_13.1/                             
11 | filesystems/cdemu         | filesystems/cdemu     | Да      | Да         |   89      | http://download.opensuse.org/repositori … SUSE_13.1/                           
15 | nVidia                    | nVidia                | Нет     | Нет        |   89      | ftp://ftp.mgts.by/pub/misc/download.nvi … suse/12.3/                                   
20 | pacman                    | pacman                | Да      | Да         |   89      | http://packman.inode.at/suse/openSUSE_13.1/                                                     
24 | stableKDE                 | stableKDE             | Нет     | Нет        |   89      | ftp://ftp.mgts.by/pub/opensuse/reposito … SUSE_12.3/                 
25 | virtualbox                | virtualbox            | Да      | Да         |   89      | http://download.virtualbox.org/virtualb … suse/12.3/                                   
27 | wine                      | wine                  | Да      | Да         |   89      | http://download.opensuse.org/repositori … SUSE_13.1/                       
2 | ExtraKDE                  | ExtraKDE              | Да      | Да         |   99      | http://download.opensuse.org/repositori … SUSE_13.1/                             
5 | Update-openSUSE           | Update-openSUSE       | Да      | Да         |   99      | http://download.opensuse.org/update/13.1/                                                       
8 | debug                     | debug/distribution    | Нет     | Нет        |   99      | http://download.opensuse.org/debug/dist … /repo/oss/                                 
9 | debug/update              | debug/update          | Нет     | Нет        |   99      | http://download.opensuse.org/debug/update/13.1/                                                 
17 | openSUSE-Non-Oss          | openSUSE-Non-Oss      | Да      | Нет        |   99      | http://download.opensuse.org/distributi … o/non-oss/                                   
18 | openSUSE-Oss              | openSUSE-Oss          | Да      | Нет        |   99      | http://download.opensuse.org/distributi … /repo/oss/                                       
19 | openSUSE-Source           | openSUSE-Source       | Нет     | Нет        |   99      | http://download.opensuse.org/source/dis … /repo/oss/                                 
21 | repo-debug-update-non-oss | Update-Debug-Non-Oss  | Нет     | Нет        |   99      | http://download.opensuse.org/debug/update/13.1-non-oss/                                         
22 | repo-update-non-oss       | Update-Non-Oss        | Да      | Да         |   99      | http://download.opensuse.org/update/13.1-non-oss/                                               
4 | Publishing                | Publishing            | Нет     | Нет        |  110      | http://download.opensuse.org/repositori … SUSE_13.1/                             
10 | devtools                  | devtools              | Нет     | Нет        |  110      | http://download.opensuse.org/repositori … SUSE_13.1/                           
12 | games                     | games                 | Нет     | Нет        |  110      | http://download.opensuse.org/repositori … SUSE_13.1/                                 
23 | security                  | security              | Нет     | Нет        |  110      | http://download.opensuse.org/repositori … SUSE_13.1/                               
26 | windowmanagers            | windowmanagers        | Да      | Да         |  110      | http://download.opensuse.org/repositori … SUSE_13.1/                   
14 | kde_cdemu/Factory         | Tumbleweed/kde_cdemu  | Нет     | Нет        |  120      | http://download.opensuse.org/repositori … umbleweed/

10

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

сегодня у меня vlc не захотел воcпроизводить mkv
вылечил переустановкой vlc и до установкой кодеков...
причем до установка без переустановки самого vlc результата не дала...

11

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

Может дописать в скрипт это:
libx264-135
libx264-135-32bit

12

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

mozgfx пишет

сегодня у меня vlc не захотел воcпроизводить mkv

Кстати, при обновлении с 12.3 почему-то совсем удаляется, а не обновляется пакет libmatroska.

13

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

mozgfx пишет

Может дописать в скрипт это:
libx264-135
libx264-135-32bit

Можно, хотя по идее ставиться должны по зависимости от x264.


з.ы. libmatroska6 тоже добавлю

14

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

его попросту нет в репах, решили все на плечи кодеков видимо переложить...
другие плееры то работали c кодеками (по крайней мере Кафеин), не работал именно VLC
Видимо завязаны на разных библиотеках...
Там есть:
x264 и libx264-135 (второй нашел через поиск...)
возможно там и крылся подвох...

15

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

verg пишет

з.ы. libmatroska6 тоже добавлю

от него толку не должно быть хотя может и будет...
Там в описании пакета написано что нужен только для компиляции собственных приложений...

16

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

mozgfx пишет

x264 и libx264-135 (второй нашел через поиск...)

В пакмане всё.

17

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

Отредактировал первое сообщение.
Добавил изменение приоритета репозиториев. Приоритет должен быть выше, чем стандартные репозитории, во избежание возможных нестыковок.

18 (19.02.2014 09:29:46 отредактировано yars)

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

При установки пакетов происходит следующее:

Разрешение зависимостей пакетов...
5 проблем:
Проблема: gstreamer-plugins-bad-orig-addon-1.2.3-5.2.x86_64 требует gstreamer-plugins-bad >= 1.2.3, но это требование не может быть удовлетворено
Проблема: gstreamer-0_10-plugins-bad-orig-addon-0.10.23-24.26.x86_64 требует libmpeg2encpp-2.0.so.0()(64bit), но это требование не может быть удовлетворено
Проблема: gstreamer-plugins-good-extra-1.2.3-2.1.x86_64 требует gstreamer-plugins-good = 1.2.3, но это требование не может быть удовлетворено
Проблема: gstreamer-plugins-ugly-orig-addon-1.2.3-2.1.x86_64 требует gstreamer-plugins-ugly >= 1.2.3, но это требование не может быть удовлетворено
Проблема: libavcodec55-2.1.3-1.2.x86_64 требует libvpx1 >= 1.3.0, но это требование не может быть удовлетворено

Проблема: gstreamer-plugins-bad-orig-addon-1.2.3-5.2.x86_64 требует gstreamer-plugins-bad >= 1.2.3, но это требование не может быть удовлетворено
  неустанавливаемые поставщики:gstreamer-plugins-bad-1.2.3-5.2.i586[packman]
                   gstreamer-plugins-bad-1.2.3-5.2.x86_64[packman]
 Решение 1: не устанавливать gstreamer-plugins-bad-1.0.10-2.5.4.x86_64
 Решение 2: не устанавливать gstreamer-plugins-bad-orig-addon-1.2.3-5.2.x86_64
 Решение 3: повредить gstreamer-plugins-bad-orig-addon-1.2.3-5.2.x86_64, игнорируя некоторые из его зависимостей

Выберите по номеру одно из указанных выше решений или пропустите, повторите попытку или отмените [1/2/3/s/r/c] (c): anatoly@linux-wgmg:~> 

Что посоветуете?


Исспользуйте теги BBCode. yars.

19

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

avre001, подождать конца сборки всех пакетов и навести порядок в своём огороде обновлений ab

20

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

avre001 пишет

Что посоветуете?

zypper lr -up

21

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

yars пишет
avre001 пишет

Что посоветуете?

zypper lr -up
#  | Псевдоним                 | Имя                                | Включён | Обновление | Приоритет | URI                                                                                  
---+---------------------------+------------------------------------+---------+------------+-----------+--------------------------------------------------------------------------------------
 1 | openSUSE-13.1-1.10        | openSUSE-13.1-1.10                 | Да      | Нет        |   99      | cd:///?devices=/dev/disk/by-id/usb-PIONEER_DVD-RW_DVRTD10RS_M6116018VF16-0:0,/dev/sr0
 2 | packman                   | packman                            | Да      | Да         |   99      | http://packman.inode.at/suse/openSUSE_13.1/                                          
 3 | repo-debug                | openSUSE-13.1-Debug                | Нет     | Да         |   99      | http://download.opensuse.org/debug/distribution/13.1/repo/oss/                       
 4 | repo-debug-update         | openSUSE-13.1-Update-Debug         | Нет     | Да         |   99      | http://download.opensuse.org/debug/update/13.1/                                      
 5 | repo-debug-update-non-oss | openSUSE-13.1-Update-Debug-Non-Oss | Нет     | Да         |   99      | http://download.opensuse.org/debug/update/13.1-non-oss/                              
 6 | repo-non-oss              | openSUSE-13.1-Non-Oss              | Да      | Да         |   99      | http://download.opensuse.org/distribution/13.1/repo/non-oss/                         
 7 | repo-oss                  | openSUSE-13.1-Oss                  | Да      | Да         |   99      | http://download.opensuse.org/distribution/13.1/repo/oss/                             
 8 | repo-source               | openSUSE-13.1-Source               | Нет     | Да         |   99      | http://download.opensuse.org/source/distribution/13.1/repo/oss/                      
 9 | repo-update               | openSUSE-13.1-Update               | Да      | Да         |   99      | http://download.opensuse.org/update/13.1/                                            
10 | repo-update-non-oss       | openSUSE-13.1-Update-Non-Oss       | Да      | Да         |   99      | http://download.opensuse.org/update/13.1-non-oss/      

22

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

avre001,
Так бывает, когда не следуешь совету в первом сообщении правильно.

Cделайте так:

Консоль: root
[root@linuxforum.ru ~]# zypper mr -p 97 packman && zypper ref && zypper dup --from=packman && zypper in gstreamer-0_10 gstreamer-0_10-plugins-base gstreamer-0_10-plugins-bad gstreamer-0_10-plugins-bad-orig-addon gstreamer-0_10-plugins-good gstreamer-0_10-plugins-good-extra gstreamer-0_10-plugins-ugly gstreamer-0_10-plugins-ugly-orig-addon faad2 libfaad2 a52dec x264 lame twolame libxine2-codecs ffmpeg w32codec-all libavcodec52 libavcodec54 MPlayer faac gecko-mediaplayer libmpg123-0 libquicktime0 libxvidcore4 libmad0 libmad0-32bit libmpeg2-0 libmac2 mpeg2dec xvidcore libdcaenc0 dirac libdirac_encoder0 libdirac_decoder0 gstreamer gstreamer-plugins-bad gstreamer-plugins-base gstreamer-plugins-good gstreamer-plugins-ugly gstreamer-plugins-ugly-orig-addon gstreamer-plugins-bad-orig-addon gstreamer-plugins-libav gstreamer-plugins-good-extra libdvdread3 libdvdplay0 libdvdnav4 libavcodec55 libavdevice52 libavdevice54 libavdevice55 libavfilter1 libavfilter2 libavfilter3 libavformat52 libavformat54 libavresample0 libavresample1 libavutil50 libavutil51 libmatroska6 libx264-135 libx264-135-32bit libvpx1 libswfdec0_9_2 && zypper dup

Одна большая команда.
1) Поднимет приоритет репозитория packman до 97.
2) Обновит списки репозиториев.
3) Далее обновление с пакмана
4) Установка всех возможных пакетов (многие уже будут установлены, о чём будет сообщено)
5) Далее полное обновление со всех реп

23

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

Я делал именно так как написано в самом начале!
Сначала команду с первой консоли потом из второй. При запуске второй команды вот это вот из топика 18 и выходит, и я не знаю что там выбрать.

24

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

avre001 пишет

Я делал именно так как написано в самом начале!

Не не сделали =)
У вашего пакмана приоритет был, что и у стандартных реп равным 99.

Запускайте команду из сообщения №22.

25

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

verg пишет
avre001 пишет

Я делал именно так как написано в самом начале!

Не не сделали =)
У вашего пакмана приоритет был, что и у стандартных реп равным 99.

Запускайте команду из сообщения №22.

Сделал еще раз, как в №22.
Вот что выдает:

Репозиторий packman не найден.
anatoly@linux-v0x7:~> 

26

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

avre001 пишет

Вот что выдает:

Покажите:

Консоль
zypper lr -up

27

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

verg пишет
avre001 пишет

Вот что выдает:

Покажите:

Консоль
zypper lr -up

anatoly@linux-v0x7:~> zypper lr -up
# | Псевдоним                 | Имя                                | Включён | Обновление | Приоритет | URI                                                                                  
--+---------------------------+------------------------------------+---------+------------+-----------+--------------------------------------------------------------------------------------
1 | openSUSE-13.1-1.10        | openSUSE-13.1-1.10                 | Да      | Нет        |   99      | cd:///?devices=/dev/disk/by-id/usb-PIONEER_DVD-RW_DVRTD10RS_M6116018VF16-0:0,/dev/sr0
2 | repo-debug                | openSUSE-13.1-Debug                | Нет     | Да         |   99      | http://download.opensuse.org/debug/distribution/13.1/repo/oss/                       
3 | repo-debug-update         | openSUSE-13.1-Update-Debug         | Нет     | Да         |   99      | http://download.opensuse.org/debug/update/13.1/                                      
4 | repo-debug-update-non-oss | openSUSE-13.1-Update-Debug-Non-Oss | Нет     | Да         |   99      | http://download.opensuse.org/debug/update/13.1-non-oss/                              
5 | repo-non-oss              | openSUSE-13.1-Non-Oss              | Да      | Да         |   99      | http://download.opensuse.org/distribution/13.1/repo/non-oss/                         
6 | repo-oss                  | openSUSE-13.1-Oss                  | Да      | Да         |   99      | http://download.opensuse.org/distribution/13.1/repo/oss/                             
7 | repo-source               | openSUSE-13.1-Source               | Нет     | Да         |   99      | http://download.opensuse.org/source/distribution/13.1/repo/oss/                      
8 | repo-update               | openSUSE-13.1-Update               | Да      | Да         |   99      | http://download.opensuse.org/update/13.1/                                            
9 | repo-update-non-oss       | openSUSE-13.1-Update-Non-Oss       | Да      | Да         |   99      | http://download.opensuse.org/update/13.1-non-oss/                                    
anatoly@linux-v0x7:~> 

28

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

avre001,
А зачем вы удалили Packman?

Выполните:

Консоль: root
[root@linuxforum.ru ~]# zypper ar -f http://packman.inode.at/suse/openSUSE_13.1/ packman && zypper ar -f http://opensuse-guide.org/repo/13.1/ libdvdcss2 && zypper mr -p 97 packman libdvdcss2 && zypper ref && zypper dup --from=packman && zypper in gstreamer-0_10 gstreamer-0_10-plugins-base gstreamer-0_10-plugins-bad gstreamer-0_10-plugins-bad-orig-addon gstreamer-0_10-plugins-good gstreamer-0_10-plugins-good-extra gstreamer-0_10-plugins-ugly gstreamer-0_10-plugins-ugly-orig-addon faad2 libfaad2 a52dec x264 lame twolame libxine2-codecs ffmpeg w32codec-all libavcodec52 libavcodec54 MPlayer faac gecko-mediaplayer libmpg123-0 libquicktime0 libxvidcore4 libmad0 libmad0-32bit libmpeg2-0 libmac2 mpeg2dec xvidcore libdcaenc0 dirac libdirac_encoder0 libdirac_decoder0 gstreamer gstreamer-plugins-bad gstreamer-plugins-base gstreamer-plugins-good gstreamer-plugins-ugly gstreamer-plugins-ugly-orig-addon gstreamer-plugins-bad-orig-addon gstreamer-plugins-libav gstreamer-plugins-good-extra libdvdread3 libdvdplay0 libdvdcss2 libdvdnav4 libavcodec55 libavdevice52 libavdevice54 libavdevice55 libavfilter1 libavfilter2 libavfilter3 libavformat52 libavformat54 libavresample0 libavresample1 libavutil50 libavutil51 libmatroska6 libx264-135 libx264-135-32bit libvpx1 libswfdec0_9_2 && zypper dup

29

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

anatoly@linux-v0x7:~> sudo zypper mr -p 97 packman && zypper ref && zypper dup --from=packman && zypper in gstreamer-0_10 gstreamer-0_10-plugins-base gstreamer-0_10-plugins-bad gstreamer-0_10-plugins-bad-orig-addon gstreamer-0_10-plugins-good gstreamer-0_10-plugins-good-extra gstreamer-0_10-plugins-ugly gstreamer-0_10-plugins-ugly-orig-addon faad2 libfaad2 a52dec x264 lame twolame libxine2-codecs ffmpeg w32codec-all libavcodec52 libavcodec54 MPlayer faac gecko-mediaplayer libmpg123-0 libquicktime0 libxvidcore4 libmad0 libmad0-32bit libmpeg2-0 libmac2 mpeg2dec xvidcore libdcaenc0 dirac libdirac_encoder0 libdirac_decoder0 gstreamer gstreamer-plugins-bad gstreamer-plugins-base gstreamer-plugins-good gstreamer-plugins-ugly gstreamer-plugins-ugly-orig-addon gstreamer-plugins-bad-orig-addon gstreamer-plugins-libav gstreamer-plugins-good-extra libdvdread3 libdvdplay0 libdvdnav4 libavcodec55 libavdevice52 libavdevice54 libavdevice55 libavfilter1 libavfilter2 libavfilter3 libavformat52 libavformat54 libavresample0 libavresample1 libavutil50 libavutil51 libmatroska6 libx264-135 libx264-135-32bit libvpx1 libswfdec0_9_2 && zypper dup
Приоритет репозитория 'packman' не изменён (97)
Нечего изменять для репозитория 'packman'.
Для обновления системных репозиториев требуются права администратора.
anatoly@linux-v0x7:~>
anatoly@linux-v0x7:~> zypper lr -up
#  | Псевдоним                 | Имя                                | Включён | Обновление | Приоритет | URI                                                                                  
---+---------------------------+------------------------------------+---------+------------+-----------+--------------------------------------------------------------------------------------
 1 | openSUSE-13.1-1.10        | openSUSE-13.1-1.10                 | Да      | Нет        |   99      | cd:///?devices=/dev/disk/by-id/usb-PIONEER_DVD-RW_DVRTD10RS_M6116018VF16-0:0,/dev/sr0
 2 | packman                   | packman                            | Да      | Да         |   97      | http://packman.inode.at/suse/openSUSE_13.1/                                          
 3 | repo-debug                | openSUSE-13.1-Debug                | Нет     | Да         |   99      | http://download.opensuse.org/debug/distribution/13.1/repo/oss/                       
 4 | repo-debug-update         | openSUSE-13.1-Update-Debug         | Нет     | Да         |   99      | http://download.opensuse.org/debug/update/13.1/                                      
 5 | repo-debug-update-non-oss | openSUSE-13.1-Update-Debug-Non-Oss | Нет     | Да         |   99      | http://download.opensuse.org/debug/update/13.1-non-oss/                              
 6 | repo-non-oss              | openSUSE-13.1-Non-Oss              | Да      | Да         |   99      | http://download.opensuse.org/distribution/13.1/repo/non-oss/                         
 7 | repo-oss                  | openSUSE-13.1-Oss                  | Да      | Да         |   99      | http://download.opensuse.org/distribution/13.1/repo/oss/                             
 8 | repo-source               | openSUSE-13.1-Source               | Нет     | Да         |   99      | http://download.opensuse.org/source/distribution/13.1/repo/oss/                      
 9 | repo-update               | openSUSE-13.1-Update               | Да      | Да         |   99      | http://download.opensuse.org/update/13.1/                                            
10 | repo-update-non-oss       | openSUSE-13.1-Update-Non-Oss       | Да      | Да         |   99      | http://download.opensuse.org/update/13.1-non-oss/                                    
anatoly@linux-v0x7:~> 

Опять добавил, но опять что-то не идет.

30

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

avre001 пишет

Для обновления системных репозиториев требуются права администратора.

Выполняйте команду от рута.
Вы используете sudo, который у вас скорее всего не настроен.

Консоль
su
НЕВИДИМЫЙ ПАРОЛЬ РУТА
ввод команды

Команда:
Консоль: root
[root@linuxforum.ru ~]# zypper ar -f http://opensuse-guide.org/repo/13.1/ libdvdcss2 && zypper mr -p 97 libdvdcss2 && zypper ref && zypper dup --from=packman && zypper in gstreamer-0_10 gstreamer-0_10-plugins-base gstreamer-0_10-plugins-bad gstreamer-0_10-plugins-bad-orig-addon gstreamer-0_10-plugins-good gstreamer-0_10-plugins-good-extra gstreamer-0_10-plugins-ugly gstreamer-0_10-plugins-ugly-orig-addon faad2 libfaad2 a52dec x264 lame twolame libxine2-codecs ffmpeg w32codec-all libavcodec52 libavcodec54 MPlayer faac gecko-mediaplayer libmpg123-0 libquicktime0 libxvidcore4 libmad0 libmad0-32bit libmpeg2-0 libmac2 mpeg2dec xvidcore libdcaenc0 dirac libdirac_encoder0 libdirac_decoder0 gstreamer gstreamer-plugins-bad gstreamer-plugins-base gstreamer-plugins-good gstreamer-plugins-ugly gstreamer-plugins-ugly-orig-addon gstreamer-plugins-bad-orig-addon gstreamer-plugins-libav gstreamer-plugins-good-extra libdvdread3 libdvdplay0 libdvdcss2 libdvdnav4 libavcodec55 libavdevice52 libavdevice54 libavdevice55 libavfilter1 libavfilter2 libavfilter3 libavformat52 libavformat54 libavresample0 libavresample1 libavutil50 libavutil51 libmatroska6 libx264-135 libx264-135-32bit libvpx1 libswfdec0_9_2 && zypper dup