31

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

Да, этого не знал.... Вроде бы пошло скачиваться.
Потом что сделать?

32

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

avre001 пишет

Потом что сделать?

Отпишитесь о результате после выполнения всех команд.

33

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

Сначала поставил 48 пакетов и обновлений, теперь пошел качать и ставить 89. Пока нормально...

34

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

Вот что пишет:

Следующий %d пакет изменит производителя:
  libxine2-pulse  openSUSE -> http://packman.links2linux.de


381 пакет для обновления, 15 новых, 1 для смены производителя.
Полный размер загрузки: 398,5 MiB. После этой операции будет использовано дополнительно 122,5 MiB.
Продолжить? [y/n/? выводит все параметры] (y): 

Мне продолжать?

35

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

avre001 пишет

Мне продолжать?

Да.

36

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

avre001,
После установки обновлений перезагрузитесь и отпишитесь о результате.

37

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

Выскочило это:

Запущены некоторые программы, использующие файлы, удалённые недавним обновлением. Возможно, некоторые необходимо перезапустить. Запустите 'zypper ps' для получения списка этих программ.
linux-v0x7:/home/anatoly # zypper ps
Следующие запущенные процессы используют удалённые файлы:

PID  | PPID | UID  | Имя пользователя | Команда                                        | Служба       | Файлы        
-----+------+------+------------------+------------------------------------------------+--------------+--------------
249  | 1    | 0    | root             | systemd-journald (deleted)                     |              | /usr/lib64/->
     |      |      |                  |                                                |              | /lib64/ld-2->
     |      |      |                  |                                                |              | /lib64/libc->
     |      |      |                  |                                                |              | /usr/lib64/->
     |      |      |                  |                                                |              | /lib64/libp->
     |      |      |                  |                                                |              | /lib64/libr->
     |      |      |                  |                                                |              | /lib64/libd->
     |      |      |                  |                                                |              | /usr/lib/sy->
588  | 1    | 491  | avahi            | avahi-daemon                                   | avahi-daemon | /lib64/libd->
     |      |      |                  |                                                |              | /lib64/libp->
     |      |      |                  |                                                |              | /lib64/ld-2->
     |      |      |                  |                                                |              | /lib64/libc->
     |      |      |                  |                                                |              | /lib64/libn->
     |      |      |                  |                                                |              | /lib64/libn->
     |      |      |                  |                                                |              | /lib64/libd->
     |      |      |                  |                                                |              | /lib64/libn->
     |      |      |                  |                                                |              | /lib64/libn->
595  | 1    | 0    | root             | wpa_supplicant                                 |              | /lib64/libs->
     |      |      |                  |                                                |              | /lib64/libd->
     |      |      |                  |                                                |              | /lib64/libc->
     |      |      |                  |                                                |              | /lib64/libd->
     |      |      |                  |                                                |              | /lib64/ld-2->
     |      |      |                  |                                                |              | /lib64/libc->
     |      |      |                  |                                                |              | /lib64/libp->
     |      |      |                  |                                                |              | /lib64/libm->
608  | 1    | 497  | messagebus       | dbus-daemon                                    |              | /lib64/libp->
     |      |      |                  |                                                |              | /lib64/ld-2->
     |      |      |                  |                                                |              | /usr/lib64/->
     |      |      |                  |                                                |              | /lib64/libc->
     |      |      |                  |                                                |              | /lib64/libr->
     |      |      |                  |                                                |              | /lib64/libd->
     |      |      |                  |                                                |              | /bin/dbus-d->
650  | 1    | 489  | polkitd          | polkitd                                        |              | /usr/lib64/->
     |      |      |                  |                                                |              | /lib64/ld-2->
     |      |      |                  |                                                |              | /usr/lib64/->
     |      |      |                  |                                                |              | /usr/lib64/->
     |      |      |                  |                                                |              | /usr/lib64/->
     |      |      |                  |                                                |              | /usr/lib64/->
     |      |      |                  |                                                |              | /usr/lib64/->
     |      |      |                  |                                                |              | /lib64/libm->
     |      |      |                  |                                                |              | /lib64/libd->
     |      |      |                  |                                                |              | /lib64/libr->
     |      |      |                  |                                                |              | /lib64/libr->
     |      |      |                  |                                                |              | /usr/lib64/->
     |      |      |                  |                                                |              | /usr/lib64/->
     |      |      |                  |                                                |              | /usr/lib64/->
     |      |      |                  |                                                |              | /lib64/libc->
     |      |      |                  |                                                |              | /lib64/libp->
674  | 1    | 0    | root             | gdbus                                          |              | /usr/lib/lo->
     |      |      |                  |                                                |              | /lib64/ld-2->
     |      |      |                  |                                                |              | /usr/lib64/->
     |      |      |                  |                                                |              | /lib64/libd->


Возможно, вам понадобится перезапустить их.
См. 'man zypper' для сведений о значениях в приведённой таблице.
linux-v0x7:/home/anatoly # 

Мне перегружать? Я еще не перегружал. Это нормально?

38

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

avre001 пишет

Мне перегружать? Я еще не перегружал. Это нормально?

Перезагружайте. Это нормально.

39

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

Спасибо БОЛЬШОЕ! Все файлы открываются стандартным плеером.
Еще раз спасибо!

40

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

Добавил в команду в первом сообщении:

libx265-10 x265

41

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

Всем доброго времени суток.
Вопрос к гуру, а если все что вы описали не помогает и vlc упорно не понимает x264 ?

42

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

gim,
Покажите:

Консоль
zypper se -si vlc
zypper lr -up

43

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

Консоль

zypper se -si vlc
Loading repository data...
Reading installed packages...

S | Name                 | Type    | Version     | Arch   | Repository
--+----------------------+---------+-------------+--------+-----------
i | libvlc-qt-devel      | package | 0.8.0-1.56  | x86_64 | packman   
i | libvlc-qt-doc        | package | 0.8.0-1.56  | noarch | packman   
i | libvlc-qt-widgets0_8 | package | 0.8.0-1.56  | x86_64 | packman   
i | libvlc-qt0_8         | package | 0.8.0-1.56  | x86_64 | packman   
i | libvlc5              | package | 2.1.4-213.6 | x86_64 | packman   
i | libvlc5-debuginfo    | package | 2.1.4-213.6 | x86_64 | packman   
i | libvlccore7          | package | 2.1.4-213.6 | x86_64 | packman   
i | vlc                  | package | 2.1.4-213.6 | x86_64 | packman   
i | vlc-codecs           | package | 2.1.4-213.6 | x86_64 | packman   
i | vlc-noX              | package | 2.1.4-213.6 | x86_64 | packman   
i | vlc-qt               | package | 2.1.4-213.6 | x86_64 | packman   


Консоль

zypper lr -up
#  | Alias                     | Name                               | Enabled | Refresh | Priority | URI                                                                   
---+---------------------------+------------------------------------+---------+---------+----------+-----------------------------------------------------------------------
1 | PlexRepo                  | PlexRepo                           | Yes     | No      |   99     | http://plex.r.worldssl.net/PlexMediaSer … se/x86_64/
2 | SuSE                      | SuSE                               | No      | No      |   99     | http://download.videolan.org/SuSE/13.1/                               
3 | google-chrome             | google-chrome                      | Yes     | Yes     |   99     | http://dl.google.com/linux/chrome/rpm/stable/x86_64                   
4 | libdvdcss                 | libdvdcss                          | Yes     | Yes     |   99     | http://opensuse-guide.org/repo/13.1/                                 
5 | openSUSE-13.1-1.10        | openSUSE-13.1-1.10                 | No      | No      |   99     | hd:///?device=/dev/disk/by-id/scsi-1KingstonDataTraveler_2.0-part1   
6 | packman                   | packman                            | Yes     | Yes     |   97     | http://packman.inode.at/suse/openSUSE_13.1/                           
7 | repo-debug                | openSUSE-13.1-Debug                | No      | Yes     |   99     | http://download.opensuse.org/debug/dist … /repo/oss/       
8 | repo-debug-update         | openSUSE-13.1-Update-Debug         | No      | Yes     |   99     | http://download.opensuse.org/debug/update/13.1/                       
9 | repo-debug-update-non-oss | openSUSE-13.1-Update-Debug-Non-Oss | No      | Yes     |   99     | http://download.opensuse.org/debug/update/13.1-non-oss/               
10 | repo-non-oss              | openSUSE-13.1-Non-Oss              | Yes     | Yes     |   99     | http://download.opensuse.org/distributi … o/non-oss/         
11 | repo-oss                  | openSUSE-13.1-Oss                  | Yes     | Yes     |   99     | http://download.opensuse.org/distributi … /repo/oss/             
12 | repo-source               | openSUSE-13.1-Source               | No      | Yes     |   99     | http://download.opensuse.org/source/dis … /repo/oss/       
13 | repo-update               | openSUSE-13.1-Update               | Yes     | Yes     |   99     | http://download.opensuse.org/update/13.1/                             
14 | repo-update-non-oss       | openSUSE-13.1-Update-Non-Oss       | Yes     | Yes     |   99     | http://download.opensuse.org/update/13.1-non-oss/       

44

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

gim,
Выполните большую команду и покажите вывод:

Консоль: root
[root@linuxforum.ru ~]# zypper in gstreamer-0_10 gstreamer-0_10-plugins-base gstreamer-0_10-plugins-bad gstreamer-0_10-plugins-bad-orig-addon gstreamer-0_10-plugins-good gstreamer-0_10-plugins-good-extra gstreamer-0_10-plugins-ugly gstreamer-0_10-plugins-ugly-orig-addon faad2 libfaad2 a52dec x264 lame twolame libxine2-codecs ffmpeg w32codec-all libavcodec52 libavcodec54 MPlayer faac gecko-mediaplayer libmpg123-0 libquicktime0 libxvidcore4 libmad0 libmad0-32bit libmpeg2-0 libmac2 mpeg2dec xvidcore libdcaenc0 dirac libdirac_encoder0 libdirac_decoder0 gstreamer gstreamer-plugins-bad gstreamer-plugins-base gstreamer-plugins-good gstreamer-plugins-ugly gstreamer-plugins-ugly-orig-addon gstreamer-plugins-bad-orig-addon gstreamer-plugins-libav gstreamer-plugins-good-extra libdvdread3 libdvdplay0 libdvdnav4 libdvdcss2 libavcodec55 libavdevice52 libavdevice54 libavdevice55 libavfilter1 libavfilter2 libavfilter3 libavformat52 libavformat54 libavresample0 libavresample1 libavutil50 libavutil51 libmatroska6 libx264-135 libx264-135-32bit libvpx1 libswfdec0_9_2 libx265-10 x265 && zypper dup --from=packman

45

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

+ открыть спойлер

Консоль

zypper in gstreamer-0_10 gstreamer-0_10-plugins-base gstreamer-0_10-plugins-bad gstreamer-0_10-plugins-bad-orig-addon gstreamer-0_10-plugins-good gstreamer-0_10-plugins-good-extra gstreamer-0_10-plugins-ugly gstreamer-0_10-plugins-ugly-orig-addon faad2 libfaad2 a52dec x264 lame twolame libxine2-codecs ffmpeg w32codec-all libavcodec52 libavcodec54 MPlayer faac gecko-mediaplayer libmpg123-0 libquicktime0 libxvidcore4 libmad0 libmad0-32bit libmpeg2-0 libmac2 mpeg2dec xvidcore libdcaenc0 dirac libdirac_encoder0 libdirac_decoder0 gstreamer gstreamer-plugins-bad gstreamer-plugins-base gstreamer-plugins-good gstreamer-plugins-ugly gstreamer-plugins-ugly-orig-addon gstreamer-plugins-bad-orig-addon gstreamer-plugins-libav gstreamer-plugins-good-extra libdvdread3 libdvdplay0 libdvdnav4 libdvdcss2 libavcodec55 libavdevice52 libavdevice54 libavdevice55 libavfilter1 libavfilter2 libavfilter3 libavformat52 libavformat54 libavresample0 libavresample1 libavutil50 libavutil51 libmatroska6 libx264-135 libx264-135-32bit libvpx1 libswfdec0_9_2 libx265-10 x265 && zypper dup --from=packman
Loading repository data...
Reading installed packages...
'libdvdcss2' is already installed.
No update candidate for 'libdvdcss2-1.2.13-5.2.x86_64'. The highest available version is already installed.
'gstreamer-plugins-base' is already installed.
No update candidate for 'gstreamer-plugins-base-1.2.4-2.12.x86_64'. The highest available version is already installed.
'ffmpeg' is already installed.
No update candidate for 'ffmpeg-2.2-2.3.x86_64'. The highest available version is already installed.
'MPlayer' is already installed.
No update candidate for 'MPlayer-1.1.1.r37203-3.1.x86_64'. The highest available version is already installed.
'gstreamer-0_10-plugins-bad' is already installed.
No update candidate for 'gstreamer-0_10-plugins-bad-0.10.23-24.56.x86_64'. The highest available version is already installed.
'gstreamer-plugins-bad' is already installed.
No update candidate for 'gstreamer-plugins-bad-1.2.4-6.19.x86_64'. The highest available version is already installed.
'gstreamer-0_10-plugins-base' is already installed.
No update candidate for 'gstreamer-0_10-plugins-base-0.10.36-12.66.x86_64'. The highest available version is already installed.
'gstreamer-0_10' is already installed.
No update candidate for 'gstreamer-0_10-0.10.36-14.33.x86_64'. The highest available version is already installed.
'lame' is already installed.
No update candidate for 'lame-3.99.5-1013.9.x86_64'. The highest available version is already installed.
'gstreamer' is already installed.
No update candidate for 'gstreamer-1.2.4-3.8.x86_64'. The highest available version is already installed.
'gstreamer-0_10-plugins-good' is already installed.
No update candidate for 'gstreamer-0_10-plugins-good-0.10.31-17.16.x86_64'. The highest available version is already installed.
'gstreamer-0_10-plugins-ugly' is already installed.
No update candidate for 'gstreamer-0_10-plugins-ugly-0.10.19-12.5.x86_64'. The highest available version is already installed.
'dirac' is already installed.
No update candidate for 'dirac-1.0.2-59.5.x86_64'. The highest available version is already installed.
'faac' is already installed.
No update candidate for 'faac-1.28-9.6.x86_64'. The highest available version is already installed.
'gstreamer-plugins-good' is already installed.
No update candidate for 'gstreamer-plugins-good-1.2.4-2.3.x86_64'. The highest available version is already installed.
'gstreamer-plugins-ugly' is already installed.
No update candidate for 'gstreamer-plugins-ugly-1.2.4-2.1.x86_64'. The highest available version is already installed.
'faad2' is already installed.
No update candidate for 'faad2-2.7-14.3.x86_64'. The highest available version is already installed.
'a52dec' is already installed.
No update candidate for 'a52dec-0.7.5svn-8.8.x86_64'. The highest available version is already installed.
'libavutil51' is already installed.
No update candidate for 'libavutil51-1.0.9-3.1.x86_64'. The highest available version is already installed.
'twolame' is already installed.
No update candidate for 'twolame-0.3.13-2.7.x86_64'. The highest available version is already installed.
'libavutil50' is already installed.
No update candidate for 'libavutil50-0.7.16-3.6.x86_64'. The highest available version is already installed.
'libdvdread3' is already installed.
No update candidate for 'libdvdread3-0.9.7-7.7.x86_64'. The highest available version is already installed.
'xvidcore' is already installed.
No update candidate for 'xvidcore-1.3.3-1.3.x86_64'. The highest available version is already installed.
'x265' is already installed.
No update candidate for 'x265-0.10hg20140324-5.1.x86_64'. The highest available version is already installed.
'libavcodec55' is already installed.
No update candidate for 'libavcodec55-2.2-2.3.x86_64'. The highest available version is already installed.
'libdvdplay0' is already installed.
No update candidate for 'libdvdplay0-1.0.1-2.5.x86_64'. The highest available version is already installed.
'x264' is already installed.
No update candidate for 'x264-0.142svn20140321-2.5.x86_64'. The highest available version is already installed.
'libavcodec52' is already installed.
No update candidate for 'libavcodec52-0.7.16-3.6.x86_64'. The highest available version is already installed.
'libavcodec54' is already installed.
No update candidate for 'libavcodec54-1.0.9-3.1.x86_64'. The highest available version is already installed.
'gstreamer-plugins-libav' is already installed.
No update candidate for 'gstreamer-plugins-libav-1.2.4-1.3.x86_64'. The highest available version is already installed.
'libdcaenc0' is already installed.
No update candidate for 'libdcaenc0-2-1.4.x86_64'. The highest available version is already installed.
'libvpx1' is already installed.
No update candidate for 'libvpx1-1.3.0-9.5.x86_64'. The highest available version is already installed.
'gecko-mediaplayer' is already installed.
No update candidate for 'gecko-mediaplayer-1.0.8-1.5.x86_64'. The highest available version is already installed.
'libmac2' is already installed.
No update candidate for 'libmac2-3.99_u4_b5_s7-1.3.x86_64'. The highest available version is already installed.
'libmpeg2-0' is already installed.
No update candidate for 'libmpeg2-0-0.5.1-2.7.x86_64'. The highest available version is already installed.
'libavdevice55' is already installed.
No update candidate for 'libavdevice55-2.2-2.3.x86_64'. The highest available version is already installed.
'libavfilter1' is already installed.
No update candidate for 'libavfilter1-0.7.16-3.6.x86_64'. The highest available version is already installed.
'libavformat52' is already installed.
No update candidate for 'libavformat52-0.7.16-3.6.x86_64'. The highest available version is already installed.
'libavformat54' is already installed.
No update candidate for 'libavformat54-1.0.9-3.1.x86_64'. The highest available version is already installed.
'libavresample1' is already installed.
No update candidate for 'libavresample1-2.2-2.3.x86_64'. The highest available version is already installed.
'libmpg123-0' is already installed.
No update candidate for 'libmpg123-0-1.18.0-1.6.x86_64'. The highest available version is already installed.
'libquicktime0' is already installed.
No update candidate for 'libquicktime0-1.2.4-70.1.x86_64'. The highest available version is already installed.
'libxvidcore4' is already installed.
No update candidate for 'libxvidcore4-1.3.3-1.3.x86_64'. The highest available version is already installed.
'libfaad2' is already installed.
No update candidate for 'libfaad2-2.7-14.3.x86_64'. The highest available version is already installed.
'libxine2-codecs' is already installed.
No update candidate for 'libxine2-codecs-1.2.5-90.5.x86_64'. The highest available version is already installed.
'libavdevice52' is already installed.
No update candidate for 'libavdevice52-0.7.16-3.6.x86_64'. The highest available version is already installed.
'libavdevice54' is already installed.
No update candidate for 'libavdevice54-1.0.9-3.1.x86_64'. The highest available version is already installed.
'libavfilter2' is already installed.
No update candidate for 'libavfilter2-1.0.9-3.1.x86_64'. The highest available version is already installed.
'libavresample0' is already installed.
No update candidate for 'libavresample0-1.0.9-3.1.x86_64'. The highest available version is already installed.
'libdirac_decoder0' is already installed.
No update candidate for 'libdirac_decoder0-1.0.2-59.5.x86_64'. The highest available version is already installed.
'libdirac_encoder0' is already installed.
No update candidate for 'libdirac_encoder0-1.0.2-59.5.x86_64'. The highest available version is already installed.
'libmad0' is already installed.
No update candidate for 'libmad0-0.15.1b-1.6.x86_64'. The highest available version is already installed.
'libswfdec0_9_2' is already installed.
No update candidate for 'libswfdec0_9_2-0.9.2-3.10.x86_64'. The highest available version is already installed.
'libx265-10' is already installed.
No update candidate for 'libx265-10-0.10hg20140324-5.1.x86_64'. The highest available version is already installed.
'gstreamer-0_10-plugins-bad-orig-addon' is already installed.
No update candidate for 'gstreamer-0_10-plugins-bad-orig-addon-0.10.23-24.56.x86_64'. The highest available version is already installed.
'gstreamer-0_10-plugins-good-extra' is already installed.
No update candidate for 'gstreamer-0_10-plugins-good-extra-0.10.31-17.16.x86_64'. The highest available version is already installed.
'gstreamer-0_10-plugins-ugly-orig-addon' is already installed.
No update candidate for 'gstreamer-0_10-plugins-ugly-orig-addon-0.10.19-12.5.x86_64'. The highest available version is already installed.
'gstreamer-plugins-bad-orig-addon' is already installed.
No update candidate for 'gstreamer-plugins-bad-orig-addon-1.2.4-6.19.x86_64'. The highest available version is already installed.
'gstreamer-plugins-good-extra' is already installed.
No update candidate for 'gstreamer-plugins-good-extra-1.2.4-2.3.x86_64'. The highest available version is already installed.
'gstreamer-plugins-ugly-orig-addon' is already installed.
No update candidate for 'gstreamer-plugins-ugly-orig-addon-1.2.4-2.1.x86_64'. The highest available version is already installed.
'mpeg2dec' is already installed.
No update candidate for 'mpeg2dec-0.5.1-2.7.x86_64'. The highest available version is already installed.
'w32codec-all' is already installed.
No update candidate for 'w32codec-all-20110131-1.2.i586'. The highest available version is already installed.
'libmad0-32bit' is already installed.
No update candidate for 'libmad0-32bit-0.15.1b-1.6.x86_64'. The highest available version is already installed.
'libdvdnav4' is already installed.
No update candidate for 'libdvdnav4-4.2.0-7.1.2.x86_64'. The highest available version is already installed.
'libmatroska6' is already installed.
No update candidate for 'libmatroska6-1.4.0-2.1.4.x86_64'. The highest available version is already installed.
'libavfilter3' not found in package names. Trying capabilities.
No provider of 'libavfilter3' found.
'libx264-135' not found in package names. Trying capabilities.
No provider of 'libx264-135' found.
'libx264-135-32bit' not found in package names. Trying capabilities.
No provider of 'libx264-135-32bit' found.
Resolving package dependencies...

Nothing to do.

46

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

gim,
Покажите:

Консоль
zypper se -si x264

47

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

Консоль

zypper se -si x264
Loading repository data...
Reading installed packages...

S | Name        | Type    | Version              | Arch   | Repository
--+-------------+---------+----------------------+--------+-----------
i | libx264-142 | package | 0.142svn20140321-2.4 | x86_64 | packman   
i | x264        | package | 0.142svn20140321-2.5 | x86_64 | packman   

48

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

gim,
Поставьте:

Консоль: root
[root@linuxforum.ru ~]# zypper in libx264-142-32bit

Проверьте видео. Вроде бы всё на месте.


Проигрывается ли видео с помощью mplayer? (Или SMPlayer?)

49

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

нет, не mplayer не SMPlayer не проигрывал... но все таки я разобрался...  bu

первое что сделал, запустил vlc -vv
и вот там самое интереное

Консоль

[0x105b0b8] main libvlc warning: cannot load module `/usr/lib64/vlc/plugins/access/libaccess_avio_plugin.so' (libvo-aacenc.so.0: cannot open shared object file: No such file or directory)
[0x105b0b8] main libvlc warning: cannot load module `/usr/lib64/vlc/plugins/codec/liblibass_plugin.so' (libass.so.4: cannot open shared object file: No such file or directory)
[0x105b0b8] main libvlc warning: cannot load module `/usr/lib64/vlc/plugins/codec/libavcodec_plugin.so' (libvo-aacenc.so.0: cannot open shared object file: No such file or directory)
[0x105b0b8] main libvlc warning: cannot load module `/usr/lib64/vlc/plugins/gui/libskins2_plugin.so' (libfribidi.so.0: cannot open shared object file: No such file or directory)
[0x105b0b8] main libvlc warning: cannot load module `/usr/lib64/vlc/plugins/demux/libavformat_plugin.so' (libvo-aacenc.so.0: cannot open shared object file: No such file or directory)
[0x105b0b8] main libvlc warning: cannot load module `/usr/lib64/vlc/plugins/text_renderer/libfreetype_plugin.so' (libfribidi.so.0: cannot open shared object file: No such file or directory)

а вот что я и забыл поставить

ну и инсталяция libvo-aacenc0 спасла отца русской демократии

Консоль

zypper install libvo-aacenc0

хотя там до сих пор vlc не все находит, будем остальное доставлять.

Спасибо большое, без вашей инструкции я бы во веке веков не разобрался

50

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

gim пишет

ну и инсталяция libvo-aacenc0 спасла отца русской демократии

Хм, по идее библиотека должна подхватываться при выполнении большой команды.

В любом случае допишу и её. Лишней не будет.

51

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

basileus пишет

Такая большая портянка в скрипт просится. ab
Кстати, лично у меня тут просится расшифровка каждого устанавливаемого пакета (что, зачем, почему). Ну так, придирки, если честно.

Если подобные просьбы будут поступать от других участников могу оформить в виде YMP файла.

52

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

mozgfx пишет
basileus пишет

Такая большая портянка в скрипт просится. ab
Кстати, лично у меня тут просится расшифровка каждого устанавливаемого пакета (что, зачем, почему). Ну так, придирки, если честно.

Если подобные просьбы будут поступать от других участников могу оформить в виде YMP файла.

вот YMP было бы просто шикарно!

53

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

gim пишет

вот YMP было бы просто шикарно!

Таки да, присоединяюсь.

54

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

Эти пакеты под вопросом пока:

55

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

Эти пакеты под вопросом пока добавлять их в общий список или нет:
gstreamer-0_10-plugins-ffmpeg
gstreamer-0_10-plugins-fluendo_mpegdemux
gstreamer-0_10-plugins-fluendo_mpegmux
k3b-codecs
h264enc
vlc-codecs
libtsmux0

dvdauthor07
vlc
smplayer
flash-player
gecko-mediaplayer

56

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

mozgfx пишет

gstreamer-0_10-plugins-ffmpeg

Автоматом вроде бы ставится.
Добавлю в список.


Остальное можно отдельным списком (даже двумя - отделить VLC)




з.ы. удалил из списка gecko-mediaplayer (пусть будет в дополнительных)

57

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

verg пишет

gecko-mediaplayer

Он вроде как нужен для обработки тега браузером. Эмуляция/замена виндового проигрывателя mplayer тег с аналогичным именем.
В 12.3 работало, а в 13.1 сломалось. Поэтому бесполезная вещь...

flash-player - вроде как тоже нет смысла включать при установке системы просят принять лицензию стоит из коробки так сказать.

58

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

mozgfx пишет

Поэтому бесполезная вещь...

Вот-вот =)

mozgfx пишет

flash-player - вроде как тоже при установке системы просят принять лицензию.

Не проблема:

Консоль: root
[root@linuxforum.ru ~]# zypper in -l flash-player

-l, --auto-agree-with-licenses
                             Автоматически отвечать 'yes' (да) на запросы
                             подтверждения лицензии стороннего поставщика.

59

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

Обновлено первое сообщение.
Добавлена команда для установки основных кодеков для openSUSE 13.2

Команду выполнять даже тем, кто обновлялся с 13.1!

60

Re: Установка мультимедиа кодеков, плагинов и поддержки DVD в openSUSE

Пока ещё не все файлы собрали видимо....

Проблема: ничто не предоставляет libstdc++.so.5, необходимый для w32codec-all-20110131-1.1.i586
Решение 1: не устанавливать w32codec-all-20110131-1.1.i586
Решение 2: повредить w32codec-all-20110131-1.1.i586, игнорируя некоторые из его зависимостей