1

Тема: Критическая удалённая уязвимость в Samba, предоставляющая root-доступ

Критическая удалённая уязвимость в Samba, предоставляющая root-доступ к серверу

Во внеплановых выпусках Samba 4.1.17, 4.0.25 и 3.6.25 устранена критическая уязвимость (CVE-2015-0240), которую можно использовать для инициирования выполнения кода на стороне сервера. Опасность проблемы усугубляется тем, что уязвимость может быть экспулатирована без проведения аутентификации - для осуществления атаки достаточно отправить несколько специально оформленных анонимных netlogon-пакетов на сетевой порт SMB/CIFS-сервера. Так как демон smbd по умолчанию выполняется с правами root, то в случае успешной атаки злоумышленник может получить root-доступ к серверу.

Проблема затрагивает все версии Samba с 3.5.0 по 4.2.0rc4. Рабочий эксплоит пока не создан, но сотрудники Red Hat положительно оценивают возможность его создания и достаточно подробно описали возможный алгоритм экплуатации. Всем пользователям Samba рекомендуется в экстренном порядке провести обновление до представленных корректирующих выпусков. Для уже не поддерживаемых веток Samba подготовлены патчи. Пользователи Samba 4 могут защититься от атаки обходным путём, отключив netlogon в настройках ("rpc_server:netlogon=disabled" в секции "[global]" smb.conf). Проблему выявили и сообщили разработчикам samba работники группы MSVR (Microsoft Vulnerability Research).


Подробности: http://www.opennet.ru/opennews/art.shtml?num=41713

2

Re: Критическая удалённая уязвимость в Samba, предоставляющая root-доступ

В Debian уже прикрыли (обновления сейчас накатил)  ab