1 (05.03.2015 21:21:38 отредактировано Bish)

Тема: не получается установить Skype на Debian 6 Squeeze

Доброго вечера! проблема: не могу установить Skype на x64 Debian. Прочитал что нужно добавить архитектуру x32 , но команда не проходит, что делать? как быть?

alex@alex:~$ sudo dpkg --add-architecture i386
dpkg: неизвестный параметр --add-architecture

Справка по установке и удалению пакетов доступна по команде dpkg --help [*];
Программа «dselect» или «aptitude» предоставляет дружественный интерфейс
управления пакетами;
Чтобы получить список значений флагов отладки dpkg, введите dpkg -Dhelp;
Чтобы получить информацию об игнорировании проблем, введите dpkg --force-help;
Чтобы получить справку по работе с файлами *.deb, введите dpkg-deb --help;

Команды, отмеченные [*], выводят большое количество информации.
Объедините их в конвейер с программами «less» или «more»!
alex@alex:~$ 

На визи все получалось, а тут не хотит. Ставил так:

sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get install libpulse0:i386
sudo wget -O skype-install.deb http://www.skype.com/go/getskype-linux-deb
sudo dpkg -i skype-install.deb
sudo apt-get install -f

2

Re: не получается установить Skype на Debian 6 Squeeze

Bish, ну правильно, "шестерка" не является мультиархитектурной. Вам придется провести работу по интеграции мультилиба (хотя бы локального, для скайпа), которую проделали разработчики Debian 7.

3

Re: не получается установить Skype на Debian 6 Squeeze

yars пишет

Bish, ну правильно, "шестерка" не является мультиархитектурной. Вам придется провести работу по интеграции мультилиба (хотя бы локального, для скайпа), которую проделали разработчики Debian 7.

Да, спасибо, я так и думал, но нашел на debian.org установку скайп на 64 битную, там тоже так же было расписано. Странно. Попробовал - все тоже самое, не проходит.

4

Re: не получается установить Skype на Debian 6 Squeeze

Слой совместимости для IA32 все-таки можно поставить: https://packages.debian.org/ru/squeeze/ia32-libs
Установка:

# apt-get install ia32-libs ia32-libs-gtk

Установка скайпа:

$ wget http://download.skype.com/linux/skype-debian_4.3.0.37-1_i386.deb -O /tmp/skype-debian_4.3.0.37-1_i386.deb
# dpkg --force-architecture -i /tmp/skype-debian_4.3.0.37-1_i386.deb

Если не запускается, смотрим вывод ldd $(which skype), собираем с --prefix=/opt нужные либы, пишем простенький скриптик, запускающий бинарник скайпа с LD_PRELOAD=/opt/lib.

5

Re: не получается установить Skype на Debian 6 Squeeze

yars пишет

Слой совместимости для IA32 все-таки можно поставить: https://packages.debian.org/ru/squeeze/ia32-libs
Установка:

# apt-get install ia32-libs ia32-libs-gtk

Установка скайпа:

$ wget http://download.skype.com/linux/skype-debian_4.3.0.37-1_i386.deb -O /tmp/skype-debian_4.3.0.37-1_i386.deb
# dpkg --force-architecture -i /tmp/skype-debian_4.3.0.37-1_i386.deb

Если не запускается, смотрим вывод ldd $(which skype), собираем с --prefix=/opt нужные либы, пишем простенький скриптик, запускающий бинарник скайпа с LD_PRELOAD=/opt/lib.

root@alex:/home/alex# apt-get install ia32-libs ia32-libs-gtk
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Уже установлена самая новая версия ia32-libs-gtk.
Уже установлена самая новая версия ia32-libs.
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
root@alex:/home/alex# 

После этого скайп установился но не запускается ac

+ открыть спойлер

root@alex:/home/alex# dpkg --force-architecture -i /tmp/skype-debian_4.3.0.37-1_i386.deb
dpkg: предупреждение: проблема игнорируется, поскольку задан параметр --force:
архитектура пакета (i386) не соответствует архитектуре системы (amd64)
Выбор ранее не выбранного пакета skype.
(Чтение базы данных ... на данный момент установлено 148774 файла и каталога.)
Распаковывается пакет skype (из файла .../skype-debian_4.3.0.37-1_i386.deb)...
dpkg: зависимости пакетов не позволяют настроить пакет skype:
skype зависит от libqt4-network (>= 4:4.8.0), однако:
  Версия libqt4-network в системе 4:4.6.3-4+squeeze1.
skype зависит от libqtcore4 (>= 4:4.7.0~beta1), однако:
  Версия libqtcore4 в системе 4:4.6.3-4+squeeze1.
skype зависит от libqtgui4 (>= 4:4.8.0), однако:
  Версия libqtgui4 в системе 4:4.6.3-4+squeeze1.
skype зависит от libqtwebkit4 (>= 2.1.0~2011week13), однако:
  Пакет libqtwebkit4 не установлен.
skype зависит от libssl1.0.0, однако:
  Пакет libssl1.0.0 не установлен.
skype зависит от libasound2-plugins, однако:
  Пакет libasound2-plugins не установлен.
dpkg: не удалось обработать параметр skype (--install):
проблемы зависимостей -- оставляем не настроенным
Обрабатываются триггеры для desktop-file-utils ...
Обрабатываются триггеры для gnome-menus ...
Обрабатываются триггеры для hicolor-icon-theme ...
При обработке следующих пакетов произошли ошибки:
skype
root@alex:/home/alex#

6

Re: не получается установить Skype на Debian 6 Squeeze

Bish, вот вам и список зависимостей. Качайте исходники пакетов отсюда: https://www.debian.org/distrib/packages, берите пакеты исходного кода для Wheezy, правьте сценарии сборки (секции, где вызывается confugure) так, чтобы пакеты ставились в /opt (./configure --prefix=/opt) и собирайте с помощью dpkg-buildpackage.

7

Re: не получается установить Skype на Debian 6 Squeeze

yars пишет

Bish, вот вам и список зависимостей. Качайте исходники пакетов отсюда: https://www.debian.org/distrib/packages, берите пакеты исходного кода для Wheezy, правьте сценарии сборки (секции, где вызывается confugure) так, чтобы пакеты ставились в /opt (./configure --prefix=/opt) и собирайте с помощью dpkg-buildpackage.

Спасибо! К сожалению, никогда этим не занимался, может быть есть где man по тому что Вы пишите? Буду рад почитать ab

8

Re: не получается установить Skype на Debian 6 Squeeze

Bish, все есть в Debian Wiki: https://www.debian.org/doc/manuals/main … ld.ru.html