1

Тема: Разрешение не получается установить.

Прошу помочь разобраться с проблемой.

Сменил монитор.
Старый был 1680x1050, новый - 1920x1200.
Новый монитор в Win7 показал своё разрешение только после подключения через аналог (переходник DVI -> D-SUB). Не знаю почему, но читал про похожие проблемы. До истины так и не добрался, но попробовал аналог - работает на винде.
На Kubuntu 14.04 выставить не удаётся.

nNvidia GTX260 (переходник DVI -> D-SUB) -> Samsung Syncmaster 244T.

2

Re: Разрешение не получается установить.

phant0m
Да причём здесь переходник и Win7?
А нарисуйте сами /etc/x11/xorg.conf?


+ открыть спойлер

# **********************************************************************
# Refer to the xorg.conf man page for details about the format of
# this file.
# **********************************************************************

Section "ServerFlags"
    Option "DontZap" "False" # disable <Ctrl><Alt><BS> (server abort)
    #DontZoom # disable <Ctrl><Alt><KP_+>/<KP_-> (resolution switching)
    AllowMouseOpenFail # allows the server to start up even if the mouse does not work
EndSection

Section "Module"
    Load "v4l" # Video for Linux
EndSection

Section "Monitor"
    Identifier "monitor1"
    VendorName "Plug'n Play"
    ModelName "L1918S "
    HorizSync 30-83
    VertRefresh 56-75
   
    # TV fullscreen mode or DVD fullscreen output.
    # 768x576 @ 79 Hz, 50 kHz hsync
    ModeLine "768x576"     50.00  768  832  846 1000   576  590  595  630
   
    # 768x576 @ 100 Hz, 61.6 kHz hsync
    ModeLine "768x576"     63.07  768  800  960 1024   576  578  590  616
EndSection

Section "Device"
    Identifier "device1"
    VendorName "NVIDIA Corporation"
    BoardName "NVIDIA GeForce 8100 to GeForce 360"
    Driver "nouveau"
    Option "DPMS"
    Option "DynamicTwinView" "false"
    Option "AddARGBGLXVisuals"
EndSection

Section "Screen"
    Identifier "screen1"
    Device "device1"
    Monitor "monitor1"
    DefaultColorDepth 24
   
    Subsection "Display"
        Depth 8
        Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
    EndSubsection
   
    Subsection "Display"
        Depth 15
        Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
    EndSubsection
   
    Subsection "Display"
        Depth 16
        Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
    EndSubsection
   
    Subsection "Display"
        Depth 24
        Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
    EndSubsection
EndSection

Section "ServerLayout"
    Identifier "layout1"
    Screen "screen1"
EndSection

Это я так, для примера. Цифры - должны быть вашими. На самом деле - всё работает. Если где ошибётесь - пишите. Фигня, всё сделаем ab

3

Re: Разрешение не получается установить.

Что говорит

xrandr

?

4 (07.03.2015 17:31:06 отредактировано phant0m)

Re: Разрешение не получается установить.

mvt пишет

phant0m
Да причём здесь переходник и Win7?

Для того чтобы доказать исправность оборудования.

Xorg.conf создавался в nvidia-settings.
У меня так как-то странно очень (Sony есть, а Samsung отсутствует):

+ открыть спойлер

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 331.20  (buildd@komainu)  Mon Feb  3 15:11:14 UTC 2014


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"

    # HorizSync source: builtin, VertRefresh source: builtin
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "SONY TV"
    HorizSync       14.0 - 49.0
    VertRefresh     48.0 - 62.0
    Option         "DPMS"
EndSection

Section "Monitor"

    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor1"
    VendorName     "Unknown"
    ModelName      "SONY TV"
    HorizSync       14.0 - 49.0
    VertRefresh     48.0 - 62.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 260"
EndSection

Section "Device"
    Identifier     "Device1"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 260"
    BusID          "PCI:1:0:0"
    Screen          1
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-0"
    Option         "metamodes" "DVI-I-2: nvidia-auto-select +0+0, DVI-I-1: nvidia-auto-select +1360+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "Device1"
    Monitor        "Monitor1"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "metamodes" "DVI-I-2: nvidia-auto-select +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

yars пишет

Что говорит

xrandr

?

Консоль
~$ xrandr
Screen 0: minimum 8 x 8, current 1152 x 864, maximum 8192 x 8192
DVI-I-0 disconnected (normal left inverted right x axis y axis)
DVI-I-1 connected primary 1152x864+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768       60.0 +
   1360x768       60.0     59.8 
   1152x864       60.0*
   800x600        72.2     60.3     56.2 
   680x384        60.0     59.8 
   640x480        59.9 
   512x384        60.0 
   400x300        72.2 
   320x240        60.1 
DVI-I-3 disconnected (normal left inverted right x axis y axis)

5 (07.03.2015 17:43:24 отредактировано mvt)

Re: Разрешение не получается установить.

phant0m пишет
mvt пишет

phant0m
Да причём здесь переходник и Win7?

Для того чтобы доказать исправность оборудования.

Xorg.conf создавался в nvidia-settings.
У меня так как-то странно очень (Sony есть, а Samsung отсутствует):

+ открыть спойлер

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 331.20  (buildd@komainu)  Mon Feb  3 15:11:14 UTC 2014


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"

    # HorizSync source: builtin, VertRefresh source: builtin
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "SONY TV"
    HorizSync       14.0 - 49.0
    VertRefresh     48.0 - 62.0
    Option         "DPMS"
EndSection

Section "Monitor"

    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor1"
    VendorName     "Unknown"
    ModelName      "SONY TV"
    HorizSync       14.0 - 49.0
    VertRefresh     48.0 - 62.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 260"
EndSection

Section "Device"
    Identifier     "Device1"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 260"
    BusID          "PCI:1:0:0"
    Screen          1
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-0"
    Option         "metamodes" "DVI-I-2: nvidia-auto-select +0+0, DVI-I-1: nvidia-auto-select +1360+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "Device1"
    Monitor        "Monitor1"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "metamodes" "DVI-I-2: nvidia-auto-select +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

yars пишет

Что говорит

xrandr

?

Консоль
~$ xrandr
Screen 0: minimum 8 x 8, current 1152 x 864, maximum 8192 x 8192
DVI-I-0 disconnected (normal left inverted right x axis y axis)
DVI-I-1 connected primary 1152x864+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768       60.0 +
   1360x768       60.0     59.8 
   1152x864       60.0*
   800x600        72.2     60.3     56.2 
   680x384        60.0     59.8 
   640x480        59.9 
   512x384        60.0 
   400x300        72.2 
   320x240        60.1 
DVI-I-3 disconnected (normal left inverted right x axis y axis)

Так хорошо же. Просто переправьте цифры под свой.
Да не в консоли. Просто - подпишите в xorg.conf.
Да я его каждый раз пишу. Монитор  отдаёт данные "по минимуму". И "фиг вам" А мне - расхлёбываться ac

6

Re: Разрешение не получается установить.

mvt,
Не получается.
Например:

Консоль
~$ xrandr --output dvi-i-1 --mode 1920x1200
warning: output dvi-i-1 not found; ignoring

7

Re: Разрешение не получается установить.

phant0m пишет

DVI-I-3 disconnected

phant0m пишет

Не получается.

дык гуглите слово disconnected. (значения).

8

Re: Разрешение не получается установить.

drBatty,
Все правильно, DVI-I-3 disconnected.

DVI-I-1 connected - вот это я пытался настроить. Через xrandr не получилось в консоли.
Вбил в xorg.conf и наконец-то получил положительный результат.

9

Re: Разрешение не получается установить.

phant0m, Читаем здесь: openSUSE 13.2 NVIDIA
...эта тема жевалась неоднократно.