1 (10.03.2015 12:39:11 отредактировано m@xim)

Тема: Проблемка с обновленим VLC.

Прилетели обновления и результат

Консоль
Ошибка: Пакет: vlc-core-2.2.0-1.fc21.x86_64 (rpmfusion-free-updates)
            Необходимо: libgpg-error.so.0(GPG_ERROR_1.0)(64bit)
Вы можете попробовать --skip-broken чтобы обойти проблему
Вы можете попробовать запустить: rpm -Va --nofiles --nodigest

Обновил систему с --skip-broken
Консоль
Пропущено (ошибка зависимостей):
vlc-core                            x86_64          2.2.0-1.fc21          rpmfusion-free-updates          9.1 M

Консоль
Пакет libgpg-error-1.13-3.fc21.x86_64 уже установлен, и это последняя версия.

Нашел друга по несчастью http://forum.fedoraonline.it/viewtopic. … 21#p229221
Что за [CENSORED]?

2

Re: Проблемка с обновленим VLC.

Решил обновление пакета до актуальной версии так

Консоль
sudo yum --enablerepo=updates-testing update libgpg-error

Консоль
[maxim@localhost ~]$ yum list installed | grep "libgpg-error"
libgpg-error.x86_64                1.17-2.fc21               @updates-testing

3

Re: Проблемка с обновленим VLC.

более изощрённый метод решения описан на багзилле rpmfusion
https://bugzilla.rpmfusion.org/show_bug.cgi?id=3560

4

Re: Проблемка с обновленим VLC.

гы ab       и в fedora bagzilla

https://admin.fedoraproject.org/updates … 59ce00fbd7

kwizart - 2015-03-09 19:38:10
Can we have a status on this update ? (Either pushed to stable or withdraw.) @tmraz please consider any, this currently breaks with vlc because the way we build package there.

5 (13.03.2015 12:59:37 отредактировано m@xim)

Re: Проблемка с обновленим VLC.

смотрю сегодня, что добавили таки

Консоль
[maxim@localhost ~]$ yum info libgpg-error
Загружены модули: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
* fedora: fedora-mirror01.rbc.ru
* rpmfusion-free: mirror.yandex.ru
* rpmfusion-free-updates: mirror.yandex.ru
* rpmfusion-nonfree: mirror.yandex.ru
* rpmfusion-nonfree-updates: mirror.yandex.ru
* updates: fedora-mirror01.rbc.ru
Установленные пакеты
Название: libgpg-error
Архитектура: x86_64
Версия: 1.17
Выпуск: 2.fc21
Объем: 426 k
Источник: installed
Из источника: updates
Аннотация: Library for error values used by GnuPG components
Ссылка: ftp://ftp.gnupg.org/gcrypt/libgpg-error/
Лицензия: LGPLv2+
Описание: This is a library that defines common error values for all GnuPG
        : components.  Among these are GPG, GPGSM, GPGME, GPG-Agent, libgcrypt,
        : pinentry, SmartCard Daemon and possibly more in the future.

Доступные пакеты
Название: libgpg-error
Архитектура: i686
Версия: 1.17
Выпуск: 2.fc21
Объем: 123 k
Источник: updates/21/x86_64
Аннотация: Library for error values used by GnuPG components
Ссылка: ftp://ftp.gnupg.org/gcrypt/libgpg-error/
Лицензия: LGPLv2+
Описание: This is a library that defines common error values for all GnuPG
        : components.  Among these are GPG, GPGSM, GPGME, GPG-Agent, libgcrypt,
        : pinentry, SmartCard Daemon and possibly more in the future.