Тема: Blender сборка

Calculating dependencies                   g             

!!! Problem resolving dependencies for media-gfx/blender
... done!

!!! The ebuild selected to satisfy "blender" has unmet requirements.
- media-gfx/blender-2.72b::gentoo USE="boost bullet dds elbeem ffmpeg game-engine nls openal openexr openmp opennl sdl sse sse2 tiff -collada -colorio -cycles -debug -doc -fftw -jack -jpeg2k -ndof -openimageio -player -redcode -sndfile" ABI_X86="64" PYTHON_TARGETS="-python3_4"

  The following REQUIRED_USE flag constraints are unsatisfied:
    python_targets_python3_4

  The above constraints are a subset of the following complete expression:
    python_targets_python3_4 player? ( game-engine ) redcode? ( jpeg2k ffmpeg ) cycles? ( boost openexr tiff ) nls? ( boost ) game-engine? ( boost )

Что-то я совсем не пойму что тут нужно делать  au

2

Re: Blender сборка

Wehrmacht_Rover пишет

python_targets_python3_4

Надо размаскировать для этого пакета, если правильно понимаю. А у него свои зависимости.

Re: Blender сборка

yars пишет
Wehrmacht_Rover пишет

python_targets_python3_4

Надо размаскировать для этого пакета, если правильно понимаю. А у него свои зависимости.

Разрулил что мог, до последнего не допру никак ac

Calculating dependencies      ... done!                      

!!! The ebuild selected to satisfy ">=media-video/libav-9[x264,mp3,encode,theora,jpeg2k?]" has unmet requirements.
- media-video/libav-9.14::gentoo USE="3dnow 3dnowext X aac alsa bindist bzip2 encode gpl hardcoded-tables mmx mmxext mp3 network openssl sdl ssl truetype vdpau vorbis x264 xvid zlib (-altivec) -amr -avx -cdio -cpudetection -custom-cflags -debug -doc -faac -fdk -frei0r -gsm -ieee1394 -jack -jpeg2k (-neon) -opus -oss -pic -pulseaudio -rtmp -schroedinger -speex -ssse3 -static-libs -test -theora -threads -tools -v4l -vaapi (-vis) -vpx" ABI_X86="64 -32 -x32"

  The following REQUIRED_USE flag constraints are unsatisfied:
    bindist? ( !openssl )

  The above constraints are a subset of the following complete expression:
    bindist? ( !faac !openssl !fdk ) rtmp? ( network ) amr? ( gpl ) aac? ( gpl ) x264? ( gpl ) X? ( gpl ) cdio? ( gpl ) test? ( encode zlib )

(dependency required by "media-gfx/blender-2.72b" [ebuild])
(dependency required by "blender" [argument])

4

Re: Blender сборка

Wehrmacht_Rover пишет

Разрулил что мог, до последнего не допру никак

И что непонятно?

Wehrmacht_Rover пишет

The following REQUIRED_USE flag constraints are unsatisfied:
    bindist? ( !openssl )

Если активирован флаг bindist, то должен быть выключён флаг openssl у пакета media-video/libav. Вообще флаг bindist отключает некоторый функционал, подпадающий под патентные ограничения, поэтому его лучше выключить.

Wehrmacht_Rover пишет

The above constraints are a subset of the following complete expression:
    bindist? ( !faac !openssl !fdk ) rtmp? ( network ) amr? ( gpl ) aac? ( gpl ) x264? ( gpl ) X? ( gpl ) cdio? ( gpl ) test? ( encode zlib )

Здесь тоже самое,
  если активирован флаг bindist, то флаги faac, openss и fdk должны быть выключены,
  если активирован флаг rtmp, то должен быть включен флаг network,
  если активирован флаг amr, то должен быть включен флаг gpl,
  если активирован флаг aac, то должен быть включен флаг gpl,
  если активирован флаг x264, то должен быть включен флаг gpl,
  если активирован флаг X, то должен быть включен флаг gpl,
  если активирован флаг cdio, то должен быть включен флаг gpl,
  если активирован флаг test, то должен быть включены флаги encode и zlib.

В тоже самое время blender по зависимостям требует, вот такие флаги у >=media-video/libav-9[x264,mp3,encode,theora,jpeg2k?].

Т.е. делаете следующее:

echo 'media-video/libav -bindist gp theora' >> /etc/portage/package.use