1

Тема: Как поставить Dolphin-emu и Pcsx2 в OpenSUSE 13.1 x64 одновременно?

Народ, может кто то  знает как поставить Dolphin-emu и Pcsx2 в OpenSUSE 13.1 x64 одновременно? (они друг на друга ругаются).

2

Re: Как поставить Dolphin-emu и Pcsx2 в OpenSUSE 13.1 x64 одновременно?

Vochatrak,
Покажите:

uname -a
zypper lr -up

Ещё три вывода, но пакеты не устанавливайте:

zypper in pcsx2 dolphin-emu
zypper in dolphin-emu
zypper in pcsx2

3

Re: Как поставить Dolphin-emu и Pcsx2 в OpenSUSE 13.1 x64 одновременно?

Первое

+ открыть спойлер
d.n.a.@linux-29u6:~> uname -a
Linux linux-29u6 3.16.2-1.gdcee397-desktop #1 SMP PREEMPT Sun Sep 7 04:40:17 UTC 2014 (dcee397) x86_64 x86_64 x86_64 GNU/Linux
d.n.a.@linux-29u6:~> zypper lr -up
#  | Псевдоним                      | Имя                                | Включён | Обновление | Приоритет | URI                                                                                      
---+--------------------------------+------------------------------------+---------+------------+-----------+------------------------------------------------------------------------------------------
 1 | Emulators                      | Emulators                          | Да      | Да         |   97      | http://download.opensuse.org/repositories/Emulators/openSUSE_13.1/                       
 2 | GNOME:Apps                     | GNOME:Apps                         | Нет     | Нет        |   99      | http://download.opensuse.org/repositories/GNOME:/Apps/openSUSE_13.1/                     
 3 | KDE:Current                    | KDE:Current                        | Да      | Да         |   99      | http://download.opensuse.org/repositories/KDE:/Current/openSUSE_13.1/                    
 4 | KDE:Extra                      | KDE:Extra                          | Да      | Да         |   97      | http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_13.1/                      
 5 | X11:Cinnamon:Factory           | X11:Cinnamon:Factory               | Нет     | Нет        |   99      | http://download.opensuse.org/repositories/X11:/Cinnamon:/Factory/openSUSE_13.1/          
 6 | devel:tools                    | devel:tools                        | Да      | Да         |   99      | http://download.opensuse.org/repositories/devel:/tools/openSUSE_13.1/                    
 7 | download.opensuse.org-games    | openSUSE BuildService - Games      | Да      | Да         |   99      | http://download.opensuse.org/repositories/games/openSUSE_13.1/                           
 8 | ftp.gwdg.de-suse               | Packman Repository                 | Да      | Да         |   97      | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_13.1/                                 
 9 | home:Herbster0815              | home:Herbster0815                  | Да      | Да         |   99      | http://download.opensuse.org/repositories/home:/Herbster0815/openSUSE_13.1/              
10 | home:Lord_LT:drivers           | home:Lord_LT:drivers               | Нет     | Да         |   99      | http://download.opensuse.org/repositories/home:/Lord_LT:/drivers/openSUSE_13.1_Update/   
11 | home:RedDwarf                  | home:RedDwarf                      | Да      | Да         |   99      | http://download.opensuse.org/repositories/home:/RedDwarf/openSUSE_13.1/                  
12 | home:RedDwarf:fakePackman      | home:RedDwarf:fakePackman          | Нет     | Нет        |   99      | http://download.opensuse.org/repositories/home:/RedDwarf:/fakePackman/openSUSE_13.1/     
13 | home:Vovochka404               | home:Vovochka404                   | Да      | Да         |   99      | http://download.opensuse.org/repositories/home:/Vovochka404/openSUSE_Factory/            
14 | home:ZaWertun:kde              | home:ZaWertun:kde                  | Да      | Да         |   99      | http://download.opensuse.org/repositories/home:/ZaWertun:/kde/openSUSE_13.1/             
15 | home:cabelo:games              | home:cabelo:games                  | Да      | Да         |   99      | http://download.opensuse.org/repositories/home:/cabelo:/games/openSUSE_13.1/             
16 | home:dvlara                    | home:dvlara                        | Да      | Да         |   99      | http://download.opensuse.org/repositories/home:/dvlara/openSUSE_13.1/                    
17 | home:endzone                   | home:endzone                       | Да      | Да         |   99      | http://download.opensuse.org/repositories/home:/endzone/openSUSE_13.1/                   
18 | home:enzokiel                  | home:enzokiel                      | Да      | Да         |   99      | http://download.opensuse.org/repositories/home:/enzokiel/openSUSE_13.1_Update/           
19 | home:malcolmlewis:Miscellanous | home:malcolmlewis:Miscellanous     | Да      | Да         |   99      | http://download.opensuse.org/repositories/home:/malcolmlewis:/Miscellanous/openSUSE_13.1/
20 | home:ykoba                     | home:ykoba                         | Да      | Да         |   99      | http://download.opensuse.org/repositories/home:/ykoba/openSUSE_13.1/                     
21 | nVidia Graphics Drivers        | nVidia Graphics Drivers            | Да      | Да         |   99      | http://download.nvidia.com/opensuse/13.1/                                                
22 | openSUSE-13.1-1.10             | openSUSE-13.1-1.10                 | Да      | Нет        |   99      | cd:///?devices=/dev/disk/by-id/ata-PIONEER_DVD-RW_DVR-220_LGQC222979WL,/dev/sr0,/dev/sr1 
23 | openSUSE:13.1:NonFree          | openSUSE:13.1:NonFree              | Да      | Да         |   99      | http://download.opensuse.org/distribution/13.1/repo/non-oss/                             
24 | opensuse-guide.org-repo        | libdvdcss repository               | Да      | Да         |   99      | http://opensuse-guide.org/repo/13.1/                                                     
25 | repo-debug                     | openSUSE-13.1-Debug                | Нет     | Да         |   99      | http://download.opensuse.org/debug/distribution/13.1/repo/oss/                           
26 | repo-debug-update              | openSUSE-13.1-Update-Debug         | Нет     | Да         |   99      | http://download.opensuse.org/debug/update/13.1/                                          
27 | repo-debug-update-non-oss      | openSUSE-13.1-Update-Debug-Non-Oss | Нет     | Да         |   99      | http://download.opensuse.org/debug/update/13.1-non-oss/                                  
28 | repo-non-oss                   | openSUSE-13.1-Non-Oss              | Нет     | Да         |   99      | http://download.opensuse.org/distribution/13.1/repo/non-oss/                             
29 | repo-oss                       | openSUSE-13.1-Oss                  | Нет     | Да         |   99      | http://download.opensuse.org/distribution/13.1/repo/oss/                                 
30 | repo-source                    | openSUSE-13.1-Source               | Нет     | Да         |   99      | http://download.opensuse.org/source/distribution/13.1/repo/oss/                          
31 | repo-update                    | openSUSE-13.1-Update               | Да      | Да         |   99      | http://download.opensuse.org/update/13.1/                                                
32 | repo-update-non-oss            | openSUSE-13.1-Update-Non-Oss       | Да      | Да         |   99      | http://download.opensuse.org/update/13.1-non-oss/                                        
33 | utilities                      | utilities                          | Да      | Да         |   99      | http://download.opensuse.org/repositories/utilities/openSUSE_13.1/                       
34 | Зеркало_OSS                    | Зеркало OSS                        | Да      | Да         |   99      | ftp://mirror.tspu.ru/opensuse/distribution/13.1/repo/oss/                                
35 | Зеркало_non-OSS                | Зеркало non-OSS                    | Да      | Да         |   99      | http://mirror.tspu.ru/opensuse/update/13.1-non-oss/                                      
36 | Ядра                           | Ядра                               | Да      | Да         |   97      | http://download.opensuse.org/repositories/Kernel:/stable/standard/                       
d.n.a.@linux-29u6:~> 

Второе

+ открыть спойлер
 zypper in pcsx2 dolphin-emu
PackageKit is blocking zypper. This happens if you have an updater applet or other software management application using PackageKit running.
Tell PackageKit to quit? [yes/no] (no): n
System management is locked by the application with pid 3835 (/usr/lib/packagekitd).
Close this application before trying again.

linux-29u6:~ # zypper in dolphin-emu
PackageKit is blocking zypper. This happens if you have an updater applet or other software management application using PackageKit running.
Tell PackageKit to quit? [yes/no] (no): n
System management is locked by the application with pid 3835 (/usr/lib/packagekitd).
Close this application before trying again.

linux-29u6:~ # zypper in pcsx2
Loading repository data...
Warning: Repository 'Зеркало non-OSS' appears to be outdated. Consider using a different mirror or server.
Reading installed packages...
Resolving package dependencies...

The following NEW package is going to be installed:
  pcsx2 

1 new package to install.
Overall download size: 2.6 MiB. After the operation, additional 10.3 MiB 
will be used.
Continue? [y/n/? shows all options] (y): n

4

Re: Как поставить Dolphin-emu и Pcsx2 в OpenSUSE 13.1 x64 одновременно?

Vochatrak,
Пара советов по репозиториям.
Эту репу:

http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_13.1/

замените на эту:

http://download.opensuse.org/repositories/KDE:/Extra/KDE_Current_openSUSE_13.1/

У этой репы экстра и репы KDE:Current поднимите приоритет до 97 и обновитесь.


Vochatrak пишет

Второе

Ещё раз эти выводы, только не держите Yast запущенным (закройте  его)

5

Re: Как поставить Dolphin-emu и Pcsx2 в OpenSUSE 13.1 x64 одновременно?

Ещё раз эти выводы, только не держите Yast запущенным (закройте  его)

+ открыть спойлер
linux-29u6:~ # zypper in pcsx2 dolphin-emu
Loading repository data...
Warning: Repository 'Зеркало non-OSS' appears to be outdated. Consider using a different mirror or server.
Reading installed packages...
Resolving package dependencies...

The following 2 NEW packages are going to be installed:
  dolphin-emu pcsx2 

2 new packages to install.
Overall download size: 4.7 MiB. After the operation, additional 18.2 MiB 
will be used.
Continue? [y/n/? shows all options] (y): 
+ открыть спойлер
linux-29u6:~ # zypper in dolphin-emu
Loading repository data...
Warning: Repository 'Зеркало non-OSS' appears to be outdated. Consider using a different mirror or server.
Reading installed packages...
Resolving package dependencies...

The following NEW package is going to be installed:
  dolphin-emu 

1 new package to install.
Overall download size: 2.1 MiB. After the operation, additional 7.9 MiB 
will be used.
Continue? [y/n/? shows all options] (y): 
+ открыть спойлер
linux-29u6:~ # zypper in pcsx2
Loading repository data...
Warning: Repository 'Зеркало non-OSS' appears to be outdated. Consider using a different mirror or server.
Reading installed packages...
Resolving package dependencies...

The following NEW package is going to be installed:
  pcsx2 

1 new package to install.
Overall download size: 2.6 MiB. After the operation, additional 10.3 MiB 
will be used.
Continue? [y/n/? shows all options] (y): 

6 (21.09.2014 19:33:40 отредактировано almukantarat)

Re: Как поставить Dolphin-emu и Pcsx2 в OpenSUSE 13.1 x64 одновременно?

Можно я присяду)

+ открыть спойлер

Консоль
uname -a
Linux almukantarat 3.16.2-48.gdcee397-desktop #1 SMP PREEMPT Sun Sep 7 04:40:17 UTC 2014 (dcee397) x86_64 x86_64 x86_64 GNU/Linux

+ открыть спойлер

Консоль
zypper lr -up
#  | Псевдоним                        | Имя                              | Включён | Обновление | Приоритет | URI                                                                           
---+----------------------------------+----------------------------------+---------+------------+-----------+--------------------------------------------------------------------------------
1 | Education                        | Education                        | Да      | Да         |   99      | http://download.opensuse.org/repositori … SUSE_13.1/             
2 | Education_Tumbleweed             | Education_Tumbleweed             | Да      | Да         |   99      | http://download.opensuse.org/repositori … umbleweed/       
3 | Emulators                        | Emulators                        | Да      | Да         |   99      | http://download.opensuse.org/repositori … SUSE_13.1/             
4 | GashaSoft                        | GashaSoft                        | Да      | Да         |   99      | dir:///media/hdd_1/Repository/openSUSE                                         
5 | Geo                              | Geo                              | Да      | Да         |   99      | http://download.opensuse.org/repositori … SUSE_13.1/     
6 | Geo_Tumbleweed                   | Geo_Tumbleweed                   | Да      | Да         |   99      | http://download.opensuse.org/repositori … umbleweed/
7 | KDE_Current                      | KDE_Current                      | Да      | Да         |   99      | http://download.opensuse.org/repositori … SUSE_13.1/         
8 | KDE_Current_Extra                | KDE_Current_Extra                | Да      | Да         |   99      | http://download.opensuse.org/repositori … SUSE_13.1/           
9 | ftp.gwdg.de-suse                 | Packman Repository               | Да      | Да         |   99      | http://ftp.gwdg.de/pub/linux/packman/su … SUSE_13.1/                       
10 | games                            | games                            | Да      | Да         |   99      | http://download.opensuse.org/repositori … SUSE_13.1/                 
11 | games_tools                      | games_tools                      | Да      | Да         |   99      | http://download.opensuse.org/repositori … SUSE_13.1/         
12 | openSUSE:Stable_OSS              | openSUSE:Stable_OSS              | Да      | Да         |   99      | http://download.opensuse.org/distributi … /repo/oss/           
13 | openSUSE:Stable_Updates          | openSUSE:Stable_Updates          | Да      | Да         |   99      | http://download.opensuse.org/update/openSUSE-current/                                                                                                           
14 | openSUSE:Stable_non-OSS          | openSUSE:Stable_non-OSS          | Да      | Да         |   99      | http://download.opensuse.org/distributi … o/non-oss/                                                                                         
15 | openSUSE:Stable_non-OSS__Updates | openSUSE:Stable_non-OSS__Updates | Да      | Да         |   99      | http://download.opensuse.org/update/ope … s-current/                                                                                                   
16 | openSUSE:Tumbleweed              | openSUSE:Tumbleweed              | Да      | Да         |   99      | http://download.opensuse.org/repositori … /standard/                                                                                         
17 | opensuse-guide.org-repo          | libdvdcss repository             | Да      | Да         |   99      | http://opensuse-guide.org/repo/13.1/                                                       

+ открыть спойлер

Консоль
sudo zypper in pcsx2 dolphin-emu                                                                                                                                                                                               
Загрузка данных о репозиториях...                                                                                                                                                                                                                                             
Чтение установленных пакетов...                                                                                                                                                                                                                                               
Разрешение зависимостей пакетов...                                                                                                                                                                                                                                             
                                                                                                                                                                                                                                                                               
Проблема: pcsx2-1.2.1+git20140916.0922-2.1.i586 требует libwx_baseu-2.8.so.0, но это требование не может быть удовлетворено                                                                                                                                                   
  неустанавливаемые поставщики:libwx_baseu-2_8-0-compat-lib-stl-2.8.12-21.1.4.i586[openSUSE:Stable_OSS]                                                                                                                                                                       
                   libwx_baseu-2_8-0-compat-lib-wxcontainer-2.8.12-21.1.4.i586[openSUSE:Stable_OSS]                                                                                                                                                                           
                   libwx_baseu-2_8-0-compat-lib-wxcontainer24c-2.8.12-21.1.4.i586[openSUSE:Stable_OSS]                                                                                                                                                                         
                   libwx_baseu-2_8-0-stl-2.8.12-21.1.4.i586[openSUSE:Stable_OSS]                                                                                                                                                                                               
                   libwx_baseu-2_8-0-wxcontainer-2.8.12-21.1.4.i586[openSUSE:Stable_OSS]                                                                                                                                                                                       
                   libwx_baseu-2_8-0-wxcontainer24c-2.8.12-21.1.4.i586[openSUSE:Stable_OSS]                                                                                                                                                                                   
Решение 1: не устанавливать pcsx2-1.2.1+git20140916.0922-2.1.i586                                                                                                                                                                                                             
Решение 2: не устанавливать dolphin-emu-4.0.2-2.1.x86_64                                                                                                                                                                                                                     
Решение 3: повредить pcsx2-1.2.1+git20140916.0922-2.1.i586, игнорируя некоторые из его зависимостей                                                                                                                                                                           
                                                                                                                                                                                                                                                                               
Выберите по номеру одно из вышеуказанных решений или отмените [1/2/3/c] (c):

+ открыть спойлер

Консоль
sudo zypper in dolphin-emu                                                                                                                                                                                                     
Загрузка данных о репозиториях...                                                                                                                                                                                                                                             
Чтение установленных пакетов...                                                                                                                                                                                                                                               
Разрешение зависимостей пакетов...                                                                                                                                                                                                                                             
                                                                                                                                                                                                                                                                               
Будут установлены следующие 9 НОВЫХ пакетов:                                                                                                                                                                                                                                   
  dolphin-emu libportaudio2 libSOIL1 libwx_baseu-2_9-4-stl libwx_baseu_net-2_9-4-compat-lib-stl libwx_gtk2u_aui-2_9-4-compat-lib-stl libwx_gtk2u_core-2_9-4-compat-lib-stl libwx_gtk2u_gl-2_9-4-compat-lib-stl wxWidgets-2_9-compat-lib-config                                 
                                                                                                                                                                                                                                                                               
9 новых пакетов для установки.                                                                                                                                                                                                                                                 
Полный размер загрузки: 3,0 MiB. После этой операции будет использовано дополнительно 10,4 MiB.                                                                                                                                                                               
Продолжить? [y/n/? выводит все параметры] (y):

+ открыть спойлер

Консоль
sudo zypper in pcsx2
Загрузка данных о репозиториях...
Чтение установленных пакетов...
Разрешение зависимостей пакетов...

Будет установлен следующий 41 НОВЫЙ пакет:
  gdk-pixbuf-query-loaders-32bit gtk2-tools-32bit libaio1-32bit libatk-1_0-0-32bit libcairo2-32bit libcanberra0-32bit libcanberra-gtk0-32bit libcanberra-gtk2-module-32bit libcelt0-2-32bit libFLAC8-32bit libgdk_pixbuf-2_0-0-32bit libgio-2_0-0-32bit libGLEW1_9-32bit
  libgraphite2-3-32bit libgtk-2_0-0-32bit libharfbuzz0-32bit libjack0-32bit libjasper1-32bit libjson0-32bit libogg0-32bit libpango-1_0-0-32bit libpixman-1-0-32bit libportaudio2-32bit libpulse0-32bit libsamplerate0-32bit libSDL2-2_0-0-32bit libsndfile1-32bit
  libSoundTouch0-32bit libspeex1-32bit libvorbis0-32bit libvorbisenc2-32bit libvorbisfile3-32bit libwx_baseu-2_8-0-compat-lib-stl libwx_gtk2u_adv-2_8-0-compat-lib-stl libwx_gtk2u_core-2_8-0-compat-lib-stl libxcb-render0-32bit libxcb-shm0-32bit libXft2-32bit
  pango-tools-32bit pcsx2 wxWidgets-compat-lib-config

41 новый пакет для установки.
Полный размер загрузки: 9,0 MiB. После этой операции будет использовано дополнительно 29,5 MiB.
Продолжить? [y/n/? выводит все параметры] (y):

Консоль
@almukantarat:/media/hdd_1/C++/pcsx2-1.2.2> ./pcsx2
./pcsx2: error while loading shared libraries: libwx_baseu-2.8.so.0: cannot open shared object file: No such file or directory

7

Re: Как поставить Dolphin-emu и Pcsx2 в OpenSUSE 13.1 x64 одновременно?

Pcsx2 из пакмана собран с wxWidgets2.8, который конфликтует с wxWidgets2.9, который нужен для Dolphin-emu.


з.ы. разве что пересобрать Pcsx2 с wxWidgets2.9

8

Re: Как поставить Dolphin-emu и Pcsx2 в OpenSUSE 13.1 x64 одновременно?

verg пишет

разве что пересобрать Pcsx2 с wxWidgets2.9

Из каких репозиториев (от других rpm дистров) можно поставить PCSX2 и Dolphin-emu, без конфликтов?

Можно ли поставить репозиторий сторонних дистров для установки и обновления
этих эмуляторов?

P.S. Прошу пошагового обьяснения. СПАСИБО.

9

Re: Как поставить Dolphin-emu и Pcsx2 в OpenSUSE 13.1 x64 одновременно?

verg пишет

з.ы. разве что пересобрать Pcsx2 с wxWidgets2.9

Не просветите? Может можно через GUI утилиты?

10 (21.09.2014 20:23:38 отредактировано almukantarat)

Re: Как поставить Dolphin-emu и Pcsx2 в OpenSUSE 13.1 x64 одновременно?

http://forums.pcsx2.net/Thread-How-to-i … nSUSE-13-1

gregory, Linux PCSX2 coder,  пишет

To use PCSX2 on openSuse:
Code:

Консоль
export LD_LIBRARY_PATH="/usr/lib/wx-2.8-stl:$LD_LIBRARY_PATH"
./bin/launch_pcsx2_linux.sh

I can't compile package for everyone but you could try the experimental wx3 options on cmake.
Code:

Консоль
./build.sh --release --wx30

А пока воз и ныне там((

11

Re: Как поставить Dolphin-emu и Pcsx2 в OpenSUSE 13.1 x64 одновременно?

В Ubntu помню, ставил оба эмулятора сразу.
Если их алиеном в rpm переделать?  Или не поможет?
И... Вариант с "симлинком" с 2.8 на 2.9 поможет?

P.S. Сейчас нет возможности, проверить самому.

12

Re: Как поставить Dolphin-emu и Pcsx2 в OpenSUSE 13.1 x64 одновременно?

Пакет libwx_baseu-2_8-0-wxcontainer24c собирается без поддержки запуска 32-битных приложений в 64-битной среде. В стандартном репозитории openSUSE отсутствует файл настройки службы OBS (baselibs.conf). Поэтому вы видите это:

almukantarat пишет

./pcsx2: error while loading shared libraries: libwx_baseu-2.8.so.0: cannot open shared object file: No such file or directory

Вам необходимо подключить этот репозиторий и установить 32-х битную зависимости вручную:

Консоль
zypper in -f libwx_baseu-2_8-0-compat-lib-wxcontainer libwx_baseu-2_8-0-compat-lib-wxcontainer24c libwx_baseu-2_8-0-stl-32bit libwx_baseu-2_8-0-wxcontainer-32bit libwx_baseu-2_8-0-wxcontainer24c-32bit

13 (23.09.2014 11:54:03 отредактировано almukantarat)

Re: Как поставить Dolphin-emu и Pcsx2 в OpenSUSE 13.1 x64 одновременно?

Пока пытался запустить уже скомпилированный pcsx2, пока пытался компилировать его, установил много всякого по зависимостям. Сейчас спокойно одновременно устанавливаются и сосуществуют Dolphin-emu и pcsx2 (из Packman).

В виртуалке попробую повторить шаги, чтоб на будущее осталось)

P.S. Установил в виртуалку openSUSE 13.1 x86-64. Добавлен только Packman

+ открыть спойлер

Консоль

:~> zypper lr
#  | Псевдоним                 | Имя                                | Включён | Обновление
---+---------------------------+------------------------------------+---------+-----------
1 | ftp.gwdg.de-suse          | Packman Repository                 | Да      | Да       
2 | openSUSE-13.1-1.10        | openSUSE-13.1-1.10                 | Да      | Нет       
3 | repo-debug                | openSUSE-13.1-Debug                | Нет     | Да       
4 | repo-debug-update         | openSUSE-13.1-Update-Debug         | Нет     | Да       
5 | repo-debug-update-non-oss | openSUSE-13.1-Update-Debug-Non-Oss | Нет     | Да       
6 | repo-non-oss              | openSUSE-13.1-Non-Oss              | Да      | Да       
7 | repo-oss                  | openSUSE-13.1-Oss                  | Да      | Да       
8 | repo-source               | openSUSE-13.1-Source               | Нет     | Да       
9 | repo-update               | openSUSE-13.1-Update               | Да      | Да       
10 | repo-update-non-oss       | openSUSE-13.1-Update-Non-Oss       | Да      | Да       

+ открыть спойлер

Консоль
:~> sudo zypper in dolphin-emu pcsx2
root's password:
Загрузка данных о репозиториях...
Чтение установленных пакетов...
Пакет 'dolphin-emu' не найден.
Разрешение зависимостей пакетов...

Будут установлены следующие 84 НОВЫХ пакета:
  alsa-oss-32bit fontconfig-32bit gdk-pixbuf-query-loaders-32bit gtk2-tools-32bit libaio1-32bit libasound2-32bit libatk-1_0-0-32bit libcairo2-32bit libcanberra0-32bit libcanberra-gtk0-32bit libcanberra-gtk2-module-32bit libcelt0-2-32bit libdrm2-32bit libdrm_intel1-32bit
  libdrm_nouveau2-32bit libdrm_radeon1-32bit libelf1-32bit libexpat1-32bit libffi4-32bit libFLAC8-32bit libfreetype6-32bit libgbm1-32bit libgdk_pixbuf-2_0-0-32bit libgio-2_0-0-32bit libGLEW1_9-32bit libglib-2_0-0-32bit libgmodule-2_0-0-32bit libgobject-2_0-0-32bit
  libgraphite2-3-32bit libgtk-2_0-0-32bit libharfbuzz0-32bit libjack0-32bit libjasper1-32bit libjson0-32bit libLLVM-32bit libltdl7-32bit libogg0-32bit libpango-1_0-0-32bit libpciaccess0-32bit libpixman-1-0-32bit libportaudio2-32bit libpulse0-32bit libsamplerate0-32bit
  libSDL2-2_0-0-32bit libsndfile1-32bit libSoundTouch0-32bit libspeex1-32bit libudev1-32bit libvorbis0-32bit libvorbisenc2-32bit libvorbisfile3-32bit libwayland-client0-32bit libwayland-server0-32bit libwrap0-32bit libwx_baseu-2_8-0-compat-lib-stl
  libwx_gtk2u_adv-2_8-0-compat-lib-stl libwx_gtk2u_core-2_8-0-compat-lib-stl libX11-6-32bit libX11-xcb1-32bit libXau6-32bit libxcb1-32bit libxcb-dri2-0-32bit libxcb-glx0-32bit libxcb-render0-32bit libxcb-shm0-32bit libxcb-xfixes0-32bit libXcomposite1-32bit
  libXcursor1-32bit libXdamage1-32bit libXext6-32bit libXfixes3-32bit libXft2-32bit libXi6-32bit libXinerama1-32bit libXrandr2-32bit libXrender1-32bit libXxf86vm1-32bit Mesa-32bit Mesa-libEGL1-32bit Mesa-libGL1-32bit Mesa-libglapi0-32bit pango-tools-32bit pcsx2
  wxWidgets-compat-lib-config

Следующий 1 рекомендованный пакет был выбран автоматически:
  alsa-oss-32bit

84 новых пакета для установки.
Полный размер загрузки: 24,2 MiB. После этой операции будет использовано дополнительно 119,5 MiB.
Продолжить? [y/n/? выводит все параметры] (y):

В Packman'e по ходу изменили пакет. Сейчас всё работает.

Ну и просто зависимости для пересборки:

+ открыть спойлер

Консоль

:~> sudo zypper si dolphin-emu                                                                                                                                                                                                                               
Чтение установленных пакетов...                                                                                                                                                                                                                                               
Загрузка данных о репозиториях...                                                                                                                                                                                                                                             
Пакет с исходным кодом 'dolphin-emu' не найден.                                                                                                                                                                                                                               
Разрешение зависимостей пакетов...                                                                                                                                                                                                                                             
                                                                                                                                                                                                                                                                               
Нечего выполнять.                 

+ открыть спойлер

Консоль

:~> sudo zypper si pcsx2
Чтение установленных пакетов...                                                                                                                                                                                                                                               
Загрузка данных о репозиториях...                                                                                                                                                                                                                                             
Разрешение зависимостей пакетов...                                                                                                                                                                                                                                             
                                                                                                                                                                                                                                                                               
Будут установлены следующие 95 НОВЫХ пакетов:                                                                                                                                                                                                                                 
  alsa-devel atk-devel cairo-devel cmake fdupes fontconfig-devel freetype2-devel gcc48-c++ gcc-c++ gdk-pixbuf-devel glew-devel glib2-devel glu-devel gtk2-devel harfbuzz-devel libaio-devel libbz2-devel libcairo-script-interpreter2 libdrm-devel libexpat-devel libgbm-devel
  libicu-devel libjpeg62 libjpeg62-devel libOSMesa9 libOSMesa-devel libpcre16-0 libpcrecpp0 libpcreposix0 libpixman-1-0-devel libpng16-compat-devel libpng16-devel libportaudio2 libSDL2-2_0-0 libSDL2-devel libSDL-devel libSoundTouch0 libstdc++48-devel libstdc++-devel     
  libudev-devel libwayland-egl-devel libwx_base-2_9-4-wxcontainer libwx_base_net-2_9-4-wxcontainer libwx_base_xml-2_9-4-wxcontainer libwx_gtk2_adv-2_9-4-wxcontainer libwx_gtk2_aui-2_9-4-wxcontainer libwx_gtk2_core-2_9-4-wxcontainer libwx_gtk2_gl-2_9-4-wxcontainer       
  libwx_gtk2_html-2_9-4-wxcontainer libwx_gtk2_media-2_9-4-wxcontainer libwx_gtk2_propgrid-2_9-4-wxcontainer libwx_gtk2_qa-2_9-4-wxcontainer libwx_gtk2_ribbon-2_9-4-wxcontainer libwx_gtk2_richtext-2_9-4-wxcontainer libwx_gtk2_stc-2_9-4-wxcontainer                       
  libwx_gtk2_webview-2_9-4-wxcontainer libwx_gtk2_xrc-2_9-4-wxcontainer libX11-devel libXau-devel libxcb-devel libxcb-dpms0 libxcb-record0 libxcb-res0 libxcb-screensaver0 libxcb-xevie0 libxcb-xf86dri0 libxcb-xinerama0 libxcb-xkb0 libxcb-xprint0 libxcb-xvmc0             
  libXdamage-devel libXext-devel libXfixes-devel libXft-devel libXrender-devel libXxf86vm-devel Mesa-devel Mesa-libEGL-devel Mesa-libglapi-devel Mesa-libGL-devel Mesa-libGLESv1_CM1 Mesa-libGLESv1_CM-devel Mesa-libGLESv2-devel Mesa-libGLESv3-devel pango-devel pcre-devel 
  portaudio-devel python-xcb-proto-devel soundtouch soundtouch-devel sparsehash-devel wayland-devel wxWidgets-2_9-ansi-devel xorg-x11-proto-devel zlib-devel                                                                                                                   
                                                                                                                                                                                                                                                                               
Будет установлен следующий 1 пакет с исходным кодом:                                                                                                                                                                                                                           
  pcsx2                                                                                                                                                                                                                                                                       
                                                                                                                                                                                                                                                                               
Следующие 2 рекомендованных пакета были выбраны автоматически:                                                                                                                                                                                                                 
  glu-devel libpng16-compat-devel                                                                                                                                                                                                                                             
                                                                                                                                                                                                                                                                               
95 новых пакетов для установки, 1 пакет с исходным кодом.                                                                                                                                                                                                                     
Полный размер загрузки: 43,2 MiB. После этой операции будет использовано дополнительно 206,7 MiB.
Продолжить? [y/n/? выводит все параметры] (y):

14

Re: Как поставить Dolphin-emu и Pcsx2 в OpenSUSE 13.1 x64 одновременно?

almukantarat пишет

В Packman'e по ходу изменили пакет. Сейчас всё работает.

Ага, только теперь дельфин вообще не стартует. Требует libwx_gtk2u_core-2.9.so.4 только она у меня установленна. (заодно и 2.8 и 3.0)

15

Re: Как поставить Dolphin-emu и Pcsx2 в OpenSUSE 13.1 x64 одновременно?

P.S. В openSUSE 13.2 Dolphin и PCSX2 нормально вместе уживаются.