Тема: Не могу установить Composer php

https://getcomposer.org/download/ установка

В общем у меня не устанавливается пишет

PHP Warning:  PHP Startup: Unable to load dynamic library 'usr/local/lib/php/ext                 ensions/no-debug-non-zts-20060613/eaccelerator.so' - usr/local/lib/php/extension                 s/no-debug-non-zts-20060613/eaccelerator.so: cannot open shared object file: No                  such file or directory in Unknown on line 0
PHP Warning:  Module 'imagick' already loaded in Unknown on line 0
Could not open input file: composer.phar

Консоль
-bash-4.1# curl -sS https://getcomposer.org/installer | php
PHP Warning:  PHP Startup: Unable to load dynamic library 'usr/local/lib/php/extensions/no-debug-non-zts-20060613/eaccelerator.so' - usr/local/lib/php/extensions/no-debug-non-zts-20060613/eaccelerator.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning:  Module 'imagick' already loaded in Unknown on line 0
#!/usr/bin/env php
Some settings on your machine may cause stability issues with Composer.
If you encounter issues, try to change the following:

Your PHP (5.3.3) is quite old, upgrading to PHP 5.3.4 or higher is recommended.
Composer works with 5.3.2+ for most people, but there might be edge case issues.

Downloading...

Composer successfully installed to: /root/composer.phar
Use it: php composer.phar


//поправил разметку
diablopc

2

Re: Не могу установить Composer php

volkodav_dark пишет

Unable to load dynamic library 'usr/local/lib/php/ext                 ensions/no-debug-non-zts-20060613/eaccelerator.so' - usr/local/lib/php/extension                 s/no-debug-non-zts-20060613/eaccelerator.so: cannot open shared object file:

либо поставьте эти библиотеки, либо отключите их загрузку в php.ini

; These are the extensions that are available for use on this PHP build.
; If you do NOT need any of these extensions, you should comment them out.
; That will probably increase both your security and performance.

Re: Не могу установить Composer php

drBatty пишет
volkodav_dark пишет

Unable to load dynamic library 'usr/local/lib/php/ext                 ensions/no-debug-non-zts-20060613/eaccelerator.so' - usr/local/lib/php/extension                 s/no-debug-non-zts-20060613/eaccelerator.so: cannot open shared object file:

либо поставьте эти библиотеки, либо отключите их загрузку в php.ini

; These are the extensions that are available for use on this PHP build.
; If you do NOT need any of these extensions, you should comment them out.
; That will probably increase both your security and performance.

Не получается не пойму что установить

4

Re: Не могу установить Composer php

volkodav_dark пишет

Не получается не пойму что установить

тогда отключайте всё, и действуйте по обстановке. Ваш скрипт напишет вам, что ему не хватает. Идите в гугл, и ищите, какой нужен пакет(ы) для вашего дистрибутива.

Hint: предварительное изучение матчасти сэкономит время и деньги. Если в деньгах вы не нуждаетесь, идите на сайт фрилансеров.

5

Re: Не могу установить Composer php

Так это же просто ворнинг. Всё же установилось.

Re: Не могу установить Composer php

Vascom пишет

Так это же просто ворнинг. Всё же установилось.

А как проверить? Просто то что должно работать не работает

7

Re: Не могу установить Composer php

Написано же, запусти:

php composer.phar

Ну и пиши что не работает и как ты этого добился.

8

Re: Не могу установить Composer php

volkodav_dark пишет

Composer successfully installed to: /root/composer.phar

Vascom пишет

Так это же просто ворнинг. Всё же установилось.

в принципе да, хотя и ректально (в каталог /root/).