<?xml version="1.0" encoding="utf-8"?>
<rss version="2.0" xmlns:atom="http://www.w3.org/2005/Atom">
	<channel>
		<title><![CDATA[Linux Forum &mdash; IP addresses]]></title>
		<link>https://linuxforum.ru/viewtopic.php?id=20647</link>
		<atom:link href="https://linuxforum.ru/extern.php?action=feed&amp;tid=20647&amp;type=rss" rel="self" type="application/rss+xml" />
		<description><![CDATA[Недавние сообщения в теме «IP addresses».]]></description>
		<lastBuildDate>Wed, 07 Mar 2012 11:05:58 +0000</lastBuildDate>
		<generator>PunBB</generator>
		<item>
			<title><![CDATA[Re: IP addresses]]></title>
			<link>https://linuxforum.ru/viewtopic.php?pid=257639#p257639</link>
			<description><![CDATA[<div class="quotebox"><cite>drBatty пишет:</cite><blockquote><div class="quotebox"><cite>Peter пишет:</cite><blockquote><p>вот &quot;arp -a&quot; вывела адрес шлюза - 192.168.0.1, это ближе всего&nbsp; к тому, что я хотел.</p></blockquote></div><p>ну попробуйте конечно этот свой arp, может что и получится <a href="http://www.opennet.ru/man.shtml?topic=arp&amp;category=7&amp;russian=0">http://www.opennet.ru/man.shtml?topic=a … ;russian=0</a></p></blockquote></div><p>arp выводит только те адреса, к которым было обращение, т.к. работает с кэшем.<br />nmap может и не баыть установлен, но с ним я ещё не разбирался.</p><p>Пётр.</p>]]></description>
			<author><![CDATA[null@example.com (Peter)]]></author>
			<pubDate>Wed, 07 Mar 2012 11:05:58 +0000</pubDate>
			<guid>https://linuxforum.ru/viewtopic.php?pid=257639#p257639</guid>
		</item>
		<item>
			<title><![CDATA[Re: IP addresses]]></title>
			<link>https://linuxforum.ru/viewtopic.php?pid=256261#p256261</link>
			<description><![CDATA[<p>обычно у меня сети с маской 24, поэтому.</p>]]></description>
			<author><![CDATA[null@example.com (riso)]]></author>
			<pubDate>Sat, 03 Mar 2012 12:35:32 +0000</pubDate>
			<guid>https://linuxforum.ru/viewtopic.php?pid=256261#p256261</guid>
		</item>
		<item>
			<title><![CDATA[Re: IP addresses]]></title>
			<link>https://linuxforum.ru/viewtopic.php?pid=256253#p256253</link>
			<description><![CDATA[<div class="quotebox"><cite>riso пишет:</cite><blockquote><p>я имел ввиду скорее человеческий фактор, нежели машинный. Обычно я говорю, задай адрес компа 192.168.1.2 и маску /24, и человек сразу понимает о чем речь.</p></blockquote></div><p>почему именно /24? Почему не /30 или даже не /31?</p>]]></description>
			<author><![CDATA[null@example.com (drBatty)]]></author>
			<pubDate>Sat, 03 Mar 2012 12:19:50 +0000</pubDate>
			<guid>https://linuxforum.ru/viewtopic.php?pid=256253#p256253</guid>
		</item>
		<item>
			<title><![CDATA[Re: IP addresses]]></title>
			<link>https://linuxforum.ru/viewtopic.php?pid=256205#p256205</link>
			<description><![CDATA[<p>я имел ввиду скорее человеческий фактор, нежели машинный. Обычно я говорю, задай адрес компа 192.168.1.2 и маску /24, и человек сразу понимает о чем речь. Извините если забил топик какой-либо глупостью.</p>]]></description>
			<author><![CDATA[null@example.com (riso)]]></author>
			<pubDate>Sat, 03 Mar 2012 10:54:43 +0000</pubDate>
			<guid>https://linuxforum.ru/viewtopic.php?pid=256205#p256205</guid>
		</item>
		<item>
			<title><![CDATA[Re: IP addresses]]></title>
			<link>https://linuxforum.ru/viewtopic.php?pid=256182#p256182</link>
			<description><![CDATA[<p><strong>riso</strong>, <br />извините, не понял, что хотели сказать, что подтвердить или опровергнуть.</p><p>address -- с англ. адрес.</p><p>192.168.1.123, 192.168.1.123/32 -- адреса хоста, никто не спорит.<br />192.168.1.123/24 -- адрес сети</p><p>Класс сети, в данном случае &quot;C&quot;, определён по первым 3 битам адреса в полном соответствии с ранее помянутым RFC870. Согласно классу приведены маска сети и адрес сети, который можно писать 192.168.1/24 или с любым числом Y как 192.168.1.Y/24.</p><p>ps. Сложилось ощущение, что употребляя слово &quot;сеть&quot;, имеете в виду что-то ещё кроме группы IP адресов с одинаковым префиксом. Задание маски кроме /32 -- уже само по себе есть указание на группу адресов из более чем одного.</p>]]></description>
			<author><![CDATA[null@example.com (bormant)]]></author>
			<pubDate>Sat, 03 Mar 2012 10:14:16 +0000</pubDate>
			<guid>https://linuxforum.ru/viewtopic.php?pid=256182#p256182</guid>
		</item>
		<item>
			<title><![CDATA[Re: IP addresses]]></title>
			<link>https://linuxforum.ru/viewtopic.php?pid=256169#p256169</link>
			<description><![CDATA[<p>хорошо, nmap действительно просканирует всю сеть, здесь я согласен с вами.<br /></p><div class="quotebox"><blockquote><p>Address:&nbsp; &nbsp; &nbsp;&nbsp; &nbsp; 192.168.1.123&nbsp; &nbsp; &nbsp; &nbsp; &nbsp;&nbsp; &nbsp;&nbsp; 11000000.10101000.00000001. 01111011<br />Netmask: &nbsp; &nbsp; 255.255.255.0 = 24 &nbsp; &nbsp;&nbsp; &nbsp; &nbsp;11111111.11111111.11111111. 00000000<br />Network:&nbsp; &nbsp; &nbsp;&nbsp; &nbsp; 192.168.1.0/24&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; 11000000.10101000.00000001. 00000000</p></blockquote></div><p><strong>Address:&nbsp; &nbsp; &nbsp;&nbsp; &nbsp; 192.168.1.123&nbsp; </strong></p>]]></description>
			<author><![CDATA[null@example.com (riso)]]></author>
			<pubDate>Sat, 03 Mar 2012 10:02:52 +0000</pubDate>
			<guid>https://linuxforum.ru/viewtopic.php?pid=256169#p256169</guid>
		</item>
		<item>
			<title><![CDATA[Re: IP addresses]]></title>
			<link>https://linuxforum.ru/viewtopic.php?pid=256122#p256122</link>
			<description><![CDATA[<div class="quotebox"><cite>riso пишет:</cite><blockquote><p>при записи 192.168.1.123/24 имеется ввиду адрес машины, а при записи 192.168.1.0/24 - адрес сети.</p></blockquote></div><p>Кем имеется? На каком основании? <br />map 192.168.1.123/24 будет сканировать только 1 хост?</p><p>Адрес хоста -- это всегда /32 (255.255.255.255).</p><p>ps. Просто примените маску и вопросов не останется.<br />x.x.x.Y &amp; 255.255.255.0 == x.x.x.0</p>]]></description>
			<author><![CDATA[null@example.com (bormant)]]></author>
			<pubDate>Sat, 03 Mar 2012 09:05:20 +0000</pubDate>
			<guid>https://linuxforum.ru/viewtopic.php?pid=256122#p256122</guid>
		</item>
		<item>
			<title><![CDATA[Re: IP addresses]]></title>
			<link>https://linuxforum.ru/viewtopic.php?pid=256119#p256119</link>
			<description><![CDATA[<div class="quotebox"><cite>drBatty пишет:</cite><blockquote><div class="quotebox"><cite>bormant пишет:</cite><blockquote><p>Сеть класса &quot;C&quot; -- 254 машины, класса &quot;B&quot; -- 65534, класса &quot;A&quot; -- 16777214.</p></blockquote></div><p>поправочка.<br /> 10.0.0.0/8&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;Private-Use Networks&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;[RFC1918] A 16777216 адресов<br /> 172.16.0.0/12&nbsp; &nbsp; &nbsp; &nbsp; Private-Use Networks&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;[RFC1918] B 1048576 адресов<br /> 192.168.0.0/16&nbsp; &nbsp; &nbsp; &nbsp;Private-Use Networks&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;[RFC1918] C 65536 адресов<br />пруф <a href="http://tools.ietf.org/html/rfc3330">http://tools.ietf.org/html/rfc3330</a></p></blockquote></div><p>В огороде бузина, а в Киеве дядька. В исходном сообщении речь о классах сетей, а в поправочке о приватных диапазонах.</p><p>RFC3330 Special-Use IPv4 Addresses описывает диапазоны адресов IPv4 специального назначения (неожиданно&nbsp; wink ).<br /><a href="http://tools.ietf.org/html/rfc1918">http://tools.ietf.org/html/rfc1918</a> говорит прямо, что под приватные адреса выделена 1 сеть класса &quot;A&quot;, 16 последовательных сетей класса B и 256 последовательных сетей класса &quot;C&quot;.<br /></p><div class="quotebox"><blockquote><p>3. Private Address Space</p><p>&nbsp; &nbsp;The Internet Assigned Numbers Authority (IANA) has reserved the<br />&nbsp; &nbsp;following three blocks of the IP address space for private internets:</p><p>&nbsp; &nbsp; &nbsp;10.0.0.0&nbsp; &nbsp; &nbsp; &nbsp; -&nbsp; &nbsp;10.255.255.255&nbsp; (10/8 prefix)<br />&nbsp; &nbsp; &nbsp;172.16.0.0&nbsp; &nbsp; &nbsp; -&nbsp; &nbsp;172.31.255.255&nbsp; (172.16/12 prefix)<br />&nbsp; &nbsp; &nbsp;192.168.0.0&nbsp; &nbsp; &nbsp;-&nbsp; &nbsp;192.168.255.255 (192.168/16 prefix)</p><p>&nbsp; &nbsp;We will refer to the first block as &quot;24-bit block&quot;, the second as<br />&nbsp; &nbsp;&quot;20-bit block&quot;, and to the third as &quot;16-bit&quot; block. Note that (in<br />&nbsp; &nbsp;pre-CIDR notation) the first block is nothing but a single class A<br />&nbsp; &nbsp;network number, <strong>while the second block is a set of 16 contiguous<br />&nbsp; &nbsp;class B network numbers, and third block is a set of 256 contiguous<br />&nbsp; &nbsp;class C network numbers</strong>.</p></blockquote></div><p>Сеть класса &quot;A&quot; -- это /8, &quot;B&quot; -- /16, &quot;C&quot; -- /24. Без вариантов. <a href="http://tools.ietf.org/html/rfc870">RFC870</a>.</p><p>Далее, поскольку 0-й и последний адрес использовать для хоста нельзя (один из них адрес сети, другой широковещательный), получим указанные в исходном сообщении цифры.</p>]]></description>
			<author><![CDATA[null@example.com (bormant)]]></author>
			<pubDate>Sat, 03 Mar 2012 09:02:09 +0000</pubDate>
			<guid>https://linuxforum.ru/viewtopic.php?pid=256119#p256119</guid>
		</item>
		<item>
			<title><![CDATA[Re: IP addresses]]></title>
			<link>https://linuxforum.ru/viewtopic.php?pid=256069#p256069</link>
			<description><![CDATA[<div class="quotebox"><blockquote><p>Он покрывает 2^(32-24) == 2^8 == 256 адресов. причём сразу.</p></blockquote></div><p>да, маска 24 покрывает 256 адресов, соглашусь. Но 123 в конце - это адрес машины. Поэтому при записи 192.168.1.123/24 имеется ввиду адрес машины, а при записи 192.168.1.0/24 - адрес сети.</p>]]></description>
			<author><![CDATA[null@example.com (riso)]]></author>
			<pubDate>Sat, 03 Mar 2012 07:26:51 +0000</pubDate>
			<guid>https://linuxforum.ru/viewtopic.php?pid=256069#p256069</guid>
		</item>
		<item>
			<title><![CDATA[Re: IP addresses]]></title>
			<link>https://linuxforum.ru/viewtopic.php?pid=256001#p256001</link>
			<description><![CDATA[<div class="quotebox"><cite>riso пишет:</cite><blockquote><p>Мне просто показалось, что вы хотите сказать, что <strong>192.168.1.123/24</strong> это адрес сети.</p></blockquote></div><p>это адрес сети и есть.<br />Он покрывает 2^(32-24) == 2^8 == 256 адресов. причём сразу.<br /></p><div class="quotebox"><cite>riso пишет:</cite><blockquote><p>На счет<strong>192.168.1/24</strong> записи спорить не буду, т.к. не применяю.</p></blockquote></div><p>очень удобно, например <strong>10/8</strong> это локальная сеть класса А.</p><p>ЗЫЖ да, для любителей венды: в первом случае маска 255.255.255.0, а во втором 255.0.0.0. ну так она пишет почему-то.</p>]]></description>
			<author><![CDATA[null@example.com (drBatty)]]></author>
			<pubDate>Fri, 02 Mar 2012 23:13:53 +0000</pubDate>
			<guid>https://linuxforum.ru/viewtopic.php?pid=256001#p256001</guid>
		</item>
		<item>
			<title><![CDATA[Re: IP addresses]]></title>
			<link>https://linuxforum.ru/viewtopic.php?pid=255963#p255963</link>
			<description><![CDATA[<p>Мне просто показалось, что вы хотите сказать, что 192.168.1.123/24 это адрес сети. На счет192.168.1/24 записи спорить не буду, т.к. не применяю.</p>]]></description>
			<author><![CDATA[null@example.com (riso)]]></author>
			<pubDate>Fri, 02 Mar 2012 20:46:08 +0000</pubDate>
			<guid>https://linuxforum.ru/viewtopic.php?pid=255963#p255963</guid>
		</item>
		<item>
			<title><![CDATA[Re: IP addresses]]></title>
			<link>https://linuxforum.ru/viewtopic.php?pid=255961#p255961</link>
			<description><![CDATA[<div class="quotebox"><cite>riso пишет:</cite><blockquote><div class="quotebox"><blockquote><p>можно и так 192.168.1.123/24 это тоже самое.</p></blockquote></div><p>это адрес машины<br /></p><div class="quotebox"><blockquote><p>192.168.1/24</p></blockquote></div><p>а это не правильная запись, т.к. тоже указана маска..</p></blockquote></div><p>обе записи рабочие. Можно проверить. Что до стандарта - лень копаться. IRL применяют обе формы, и не комплексуют.</p>]]></description>
			<author><![CDATA[null@example.com (drBatty)]]></author>
			<pubDate>Fri, 02 Mar 2012 20:41:15 +0000</pubDate>
			<guid>https://linuxforum.ru/viewtopic.php?pid=255961#p255961</guid>
		</item>
		<item>
			<title><![CDATA[Re: IP addresses]]></title>
			<link>https://linuxforum.ru/viewtopic.php?pid=255955#p255955</link>
			<description><![CDATA[<div class="quotebox"><blockquote><p>можно и так 192.168.1.123/24 это тоже самое.</p></blockquote></div><p>это адрес машины<br /></p><div class="quotebox"><blockquote><p>192.168.1/24</p></blockquote></div><p>а это не правильная запись, т.к. тоже указана маска..</p>]]></description>
			<author><![CDATA[null@example.com (riso)]]></author>
			<pubDate>Fri, 02 Mar 2012 20:35:05 +0000</pubDate>
			<guid>https://linuxforum.ru/viewtopic.php?pid=255955#p255955</guid>
		</item>
		<item>
			<title><![CDATA[Re: IP addresses]]></title>
			<link>https://linuxforum.ru/viewtopic.php?pid=255953#p255953</link>
			<description><![CDATA[<div class="quotebox"><cite>riso пишет:</cite><blockquote><p>естественно я имел ввиду адрес сети smile и маску же дописал..</p></blockquote></div><p>угу. уверен, многие не поймут.<br /></p><div class="quotebox"><cite>riso пишет:</cite><blockquote><p>если я допишу что угодно, то это будет адрес машины, а не сети.</p></blockquote></div><p>нет. там можно писать всё что угодно, или вообще не писать ничего 192.168.1/24<br />можно и так 192.168.1.123/24 это тоже самое.<br />Но таки правильнее ничего не писать, или писать ноль.</p>]]></description>
			<author><![CDATA[null@example.com (drBatty)]]></author>
			<pubDate>Fri, 02 Mar 2012 20:30:37 +0000</pubDate>
			<guid>https://linuxforum.ru/viewtopic.php?pid=255953#p255953</guid>
		</item>
		<item>
			<title><![CDATA[Re: IP addresses]]></title>
			<link>https://linuxforum.ru/viewtopic.php?pid=255932#p255932</link>
			<description><![CDATA[<p><strong>drBatty</strong>, естественно я имел ввиду адрес сети <img src="https://linuxforum.ru/img/smilies/ab.gif" alt="ab" /> и маску же дописал..<br /></p><div class="quotebox"><blockquote><p>Что касается последнего нуля, то с учётом /24 (работают 24 первых бита) там можно писать вообще что угодно, но принято писать 0.</p></blockquote></div><p>если я допишу что угодно, то это будет адрес машины, а не сети.</p>]]></description>
			<author><![CDATA[null@example.com (riso)]]></author>
			<pubDate>Fri, 02 Mar 2012 19:07:14 +0000</pubDate>
			<guid>https://linuxforum.ru/viewtopic.php?pid=255932#p255932</guid>
		</item>
	</channel>
</rss>
