<?xml version="1.0" encoding="utf-8"?>
<rss version="2.0" xmlns:atom="http://www.w3.org/2005/Atom">
	<channel>
		<title><![CDATA[Linux Forum &mdash; Выпуск мультимедиа-пакета FFmpeg 2.6]]></title>
		<link>https://linuxforum.ru/viewtopic.php?id=37896</link>
		<atom:link href="https://linuxforum.ru/extern.php?action=feed&amp;tid=37896&amp;type=rss" rel="self" type="application/rss+xml" />
		<description><![CDATA[Недавние сообщения в теме «Выпуск мультимедиа-пакета FFmpeg 2.6».]]></description>
		<lastBuildDate>Sun, 08 Mar 2015 02:57:21 +0000</lastBuildDate>
		<generator>PunBB</generator>
		<item>
			<title><![CDATA[Выпуск мультимедиа-пакета FFmpeg 2.6]]></title>
			<link>https://linuxforum.ru/viewtopic.php?pid=448214#p448214</link>
			<description><![CDATA[<p><a href="http://ffmpeg.org/download.html#releases">Доступен</a> мультимедиа-пакет <a href="http://ffmpeg.org/">FFmpeg 2.6</a>, включающий набор приложений и коллекцию библиотек для операций над различными мультимедиа-форматами (запись, преобразование и декодирование звуковых и видеоформатов). Кроме изменений, созданных внутри проекта, в новую версию также включены все последние наработки, развиваемые в ветках <a href="http://gitorious.org/ffmpeg/ffmpeg-mt">ffmpeg-mt</a> (многопоточное декодирование) и <a href="http://libav.org/">libav</a> (форк FFmpeg). Пакет распространяется под лицензиями LGPL и GPL, разработка FFmpeg ведётся смежно с проектом MPlayer.</p><p>Из <a href="http://git.videolan.org/?p=ffmpeg.git;a=blob;f=RELEASE_NOTES;hb=release/2.6">изменений</a>, <a href="http://git.videolan.org/?p=ffmpeg.git;a=blob;f=Changelog;hb=release/2.6">добавленных</a> в FFmpeg 2.6, можно выделить:<br /></p><ul><li><p>Добавлен кодировщик <a href="http://en.wikipedia.org/wiki/Nvidia_NVENC">NVENC</a>, использующий одноимённый механизм ускорения кодирования H.264, встроенный в современные GPU NVIDIA;</p></li><li><p>Поддержка ускорения декодиования потоков H.264 средствами Intel QSV (<a href="https://ru.wikipedia.org/wiki/Intel_Quick_Sync_Video">Intel Quick Sync Video</a>);</p></li><li><p>В фильтр spp добавлена поддержка 10-битых выборок (sample);</p></li><li><p>Добавлен фильтр colorlevels для обработки цветности;</p></li><li><p>Реализован фильтр tblend для отображения отличий между последовательными кадрами;</p></li><li><p>Добавлен звуковой фильтр dcshift;</p></li><li><p>В libavfilter представлены фильтры palettegen и paletteuse, позволяющие создавать высококачественные палитры для GIF-файлов.</p></li><li><p>Добавлен фильтр showpalette;</p></li><li><p>Прекращена поддержка прослойки libmpcodecs (фильтры MPlayer). Актуальные фильтры MPlayer (softpulldown/repeatfields, eq*, фильтры постобработки fspp, uspp, pp7) портированы в FFmpeg и больше не требуют дополнительной прослойки;</p></li><li><p><a href="http://git.videolan.org/?p=ffmpeg.git;a=blob;f=doc/APIchanges;h=3f153e9faf4d48f7896220f08ba508719d3d9f49;hb=HEAD">Расширен API</a>, добавлены новые вызовы avdevice_list_input_sources(), avdevice_list_output_sinks(), av_dv_codec_profile2(), av_vdpau_get_surface_parameters(), avformat_flush(), avio_put_str16be(). Для получения списка источников ввода и систем вывода в утилиту ffmpeg следует использовать опции &quot;-sources&quot; и &quot;-sinks&quot;;</p></li><li><p>Внесены оптимизации в декодировщик VP9, который теперь пригоден для использования на 32-разрядных системах x86 и на CPU без поддержки инструкций SSSE3, таких как Phenom (даже двухядерного Athlon теперь достаточно для декодирования VP9-видео 1080p 30fps).</p></li><li><p>В декодировщик HEVC/H.265 внесены многочисленные ассемблерные и Си-оптимизации. В стек HEVC добавлена поддержка оптимизации для архитектуры ARM, основанной на использовании инструкций NEON;</p></li><li><p>В код обработки звука в libavcodec добавлены ассемблерные оптимизации для процессоров MIPS64;</p></li><li><p>Добавлена поддержка формата RIFX для файлов WAV;</p></li><li><p>Добавлен упаковщик медиаконтейнеров (muxer) RTP/mpegts</p></li><li><p>Добавлена поддержка симметричных блочных шифров Camellia и Twofish ;</p></li><li><p>Реализована обвязка над кодировщиком OpenH264;</p></li><li><p>Поддержка позиционирования внутри файлов VOC;</p></li><li><p>Поддержка разрешения DNx100 (960x720@8)</p></li><li><p>Добавлены модули для восстановления данных из пакетов RTP (depacketizer) для звуковых payload-форматов VP9, DV (RFC 6469), AC3 (RFC 4184), T.140 (RFC 4103) и MP3 (RFC 5219)</p></li><li><p>Добавлен декодировщик DSS-SP (Digital Speech Standard / Standard Play). </p></li></ul><br /><p>Источник: <a href="http://www.opennet.ru/opennews/art.shtml?num=41805">http://www.opennet.ru/opennews/art.shtml?num=41805</a></p>]]></description>
			<author><![CDATA[null@example.com (verg)]]></author>
			<pubDate>Sun, 08 Mar 2015 02:57:21 +0000</pubDate>
			<guid>https://linuxforum.ru/viewtopic.php?pid=448214#p448214</guid>
		</item>
	</channel>
</rss>
