<?xml version="1.0" encoding="utf-8"?>
<rss version="2.0" xmlns:atom="http://www.w3.org/2005/Atom">
	<channel>
		<title><![CDATA[Linux Forum &mdash; Квартальный отчет о развитии FreeBSD за июль—сентябрь 2010 [LOR]]]></title>
		<link>https://linuxforum.ru/viewtopic.php?id=7804</link>
		<atom:link href="https://linuxforum.ru/extern.php?action=feed&amp;tid=7804&amp;type=rss" rel="self" type="application/rss+xml" />
		<description><![CDATA[Недавние сообщения в теме «Квартальный отчет о развитии FreeBSD за июль—сентябрь 2010 [LOR]».]]></description>
		<lastBuildDate>Fri, 29 Oct 2010 04:26:04 +0000</lastBuildDate>
		<generator>PunBB</generator>
		<item>
			<title><![CDATA[Re: Квартальный отчет о развитии FreeBSD за июль—сентябрь 2010 [LOR]]]></title>
			<link>https://linuxforum.ru/viewtopic.php?pid=106250#p106250</link>
			<description><![CDATA[<p>что я один что ли только на 7.3&nbsp; сижу?&nbsp; <img src="https://linuxforum.ru/img/smilies/ac.gif" alt="ac" />&nbsp; пора 8ку накатывать&nbsp; smile</p>]]></description>
			<author><![CDATA[null@example.com (i2ks)]]></author>
			<pubDate>Fri, 29 Oct 2010 04:26:04 +0000</pubDate>
			<guid>https://linuxforum.ru/viewtopic.php?pid=106250#p106250</guid>
		</item>
		<item>
			<title><![CDATA[Re: Квартальный отчет о развитии FreeBSD за июль—сентябрь 2010 [LOR]]]></title>
			<link>https://linuxforum.ru/viewtopic.php?pid=106235#p106235</link>
			<description><![CDATA[<p>&quot;да свершится предначертанное!!&quot; ура товарищи! а по поводу ЛОРа - я даже не волнуюсь по этому поводу!!! Развели там балаган!</p>]]></description>
			<author><![CDATA[null@example.com (zaG)]]></author>
			<pubDate>Thu, 28 Oct 2010 23:10:00 +0000</pubDate>
			<guid>https://linuxforum.ru/viewtopic.php?pid=106235#p106235</guid>
		</item>
		<item>
			<title><![CDATA[Re: Квартальный отчет о развитии FreeBSD за июль—сентябрь 2010 [LOR]]]></title>
			<link>https://linuxforum.ru/viewtopic.php?pid=106107#p106107</link>
			<description><![CDATA[<p>фу блин, почитал ЛОР, осьпади, там одни дети отписались.<br />использую девятку, порты обновляются каждый день по десятке. очень активно пилят.</p>]]></description>
			<author><![CDATA[null@example.com (system-root)]]></author>
			<pubDate>Thu, 28 Oct 2010 17:30:09 +0000</pubDate>
			<guid>https://linuxforum.ru/viewtopic.php?pid=106107#p106107</guid>
		</item>
		<item>
			<title><![CDATA[Квартальный отчет о развитии FreeBSD за июль—сентябрь 2010 [LOR]]]></title>
			<link>https://linuxforum.ru/viewtopic.php?pid=106063#p106063</link>
			<description><![CDATA[<p>В этом отчёте перечислены проекты с разной степенью готовности — от принятых в STABLE, до таких, которые даже для CURRENT не готовы и разрабатываются в отдельной версии исходных кодов ОС.</p><p>Из-за большого количества текста статьи сильно сокращены, изменена группировка статей, в перевод не включена информация о модификации давно существующего функционала, о развитии в документации, о мероприятиях сообщества и отчёты отдельных команд: bugbusting, KDE, releng.</p><p><strong>Ядро и базовая система</strong></p><p>Ведётся работа по разработке контейнеров ресурсов и механизма управления ресурсами для jail. Уже реализован фреймворк по управлению абстрактными ресурсами, готов механизм установки ограничений для большинства имеющихся в системе ресурсов, ведутся работы по добавлению поддержки оставшихся ресурсов, отладке и общему улучшению кода.<br />Расширен функционал встроенного демона SNMP — добавлены модуль snmp_wlan, поддержка шифрования и аутентификации SNMPv3, модуль snmp_usm для конфигурирования пользовательских параметров SNMPv3 (RFC3414), модуль snmp_vacm, который позволяет управлять доступом к поддеревьям MIB на базе логинов-паролей (RFC3415).<br />Ведутся работы по реализации проекта CAPSICUM, который расширяет POSIX API несколькими новыми примитивами ОС, позволяющими включать режим sandbox для процессов и анонимных объектов в разделяемой памяти. Также предоставляется модифицированная среда исполнения С, поддерживающая распределённые приложения, работающие в режиме sandbox.<br />Новая инфраструктура временных событий ядра — написан новый аппаратно-независимый код управления событиями, который поддерживает старый режим периодических событий и новый режим разовых событий. В результате становится возможным эффективное использование состояний простоя процессора (CPU C-states), что уменьшает потребление и увеличивает результативность технологии Intel TurboBoost.<br />Разрабатывается режим дампа ядра через сеть — реализован минимальный стек tcp/ipv4, используется свой UDP-протокол для передачи дампа на сетевое устройство.<br />Userland DTrace — реализована поддержка механизма динамической отладки Dtrace для пользовательских программ, как это сделано в OpenSolaris. Также поддержка DTrace включена в порты mysql-server и postgresql-server.<br />Новая система мониторинга и управления системными службами (Freebsd Services control) — набор бинарных файлов, интегрированных с системой инициализации rc.d. Состоит из фоновой службы fscd, которая управляется через утилиту fscadm. Реализация системы частично основана на идеях daemontools и solaris service management facility.<br /><strong>Оборудование и драйвера</strong></p><p>Завершён проект по портированию фреймворка DAHDI (Digium/Asterisk Hardware Device Interface) и соответствующего набора драйверов для оборудования E1/T1, цифровых ISDN и аналоговых FXO/FXS-карт.<br />В эмуляторе Linux появилась поддержка V4L. Изменения внесены в ветку 8-stable и позволяют использовать видеокамеры, поддерживаемые драйверами pwcbsd или video4bsd.<br />В ветке CURRENT появилась поддержка USB 3.0 и чипсета Intel XHCI.<br /><strong>Сетевой стек</strong></p><p>Разрабатывается новая система захвата пакетов, ориентированная на высокоскоростные сети. Текущее состояние: реализована фильтрация через BPF для ядра и пользовательских приложений, готова поддержка Intel 8254х, частично реализована работа с драйвером ixgbe для захвата пакетов на скорости 10GB.<br />В ветку CURRENT внесены изменения для модернизации работы протокола TCP. Реализована поддержка RFC3465 (Appropriate Byte Counting), улучшена работа очереди сборки TCP-пакетов, портирован инструмент для анализа статистики TCP на основе технологии CAIA Statistical Information for TCP Research (SIFTR).<br />Начаты работы по реализации шести ядерных модулей с алгоритмами управления TCP (congestion control) — NewReno, HTCP, CUBIC, Vegas, HD, CHD. Подробности <a href="http://caia.swin.edu.au/urp/newtcp/tools.html">по адресу</a>. Предполагается, что реализация этих планов резко выделит FreeBSD из ряда остальных ОС в области сетевых задач.<br /><strong>Файловые системы</strong></p><p>Новая криптографическая файловая система уровня ядра (PEFS) для прозрачного шифрования данных независимо от нижележащей ФС.<br />Портирование openAFS — распределенной сетевой файловой системы, возникшей из проекта Carnegie-Mellon University. Код клиента достаточно функционален, поэтому планируется в ближайшее время создать порт openafs-devel.<br />В код FreeBSD импортирована ZFSv28 в режиме массового тестирования. Главная особенность этой версии — поддержка дедупликации.<br /><strong>Поддержка аппаратных архитектур</strong></p><p>Ветка CURRENT работает на AR9132 SoC (используется, например, для TP-Link TP-WN1043ND 802.11n wireless bridge/router). Пока ещё не поддерживаются USB и чипы Ethernet Realtek Gigabit switch/PHY.<br />Начаты работы по созданию ARM-версии FreeBSD. Пока на совсем ранней стадии — знакомство с ARM-структурой и исходными текстами MicroC OS.<br />Версия FreeBSD/powerpc64 загружается и работает в режиме multiuser SMP на приставке PlayStation3. Открытые задачи: поддержка SATA, поддержка Cell SPU, модернизация загрузчика для интерактивного взаимодействия с пользователем на ранней стадии загрузки (user input at the loader input).<br />FreeBSD/mips on Octeon — коды проекта перенесены в CURRENT. Достигнута стабильная работа на двухъядерной системе, проведено тестирование работоспособности на системах с числом ядер до 16. Много открытых задач в поддержке оборудования (pci, usb, ethernet).<br />Ветка FreeBSD/mips портирована на D-Link DAP-1350 (Ralink RT3052F SoC) и D-Link DIR-320 (BCM5354 SoC). Однако, пока ещё нет полной поддержки всех возможностей оборудования.<br /><a href="http://www.freebsd.org/news/status/report-2010-07-2010-09.html">http://www.freebsd.org/news/status/repo … 10-09.html</a></p>]]></description>
			<author><![CDATA[null@example.com (renegat)]]></author>
			<pubDate>Thu, 28 Oct 2010 16:13:43 +0000</pubDate>
			<guid>https://linuxforum.ru/viewtopic.php?pid=106063#p106063</guid>
		</item>
	</channel>
</rss>
