Итак продолжаются мои попытки настроить CentOS minimal под свои нужды (mail сервером он должен работать)
Итак выполняю:
[root@localhost ~]# yum install postfix
Loaded plugins: fastestmirror, presto
Loading mirror speeds from cached hostfile
base | 3.7 kB 00:00
updates | 3.5 kB 00:00
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package postfix.i386 2:2.8.7-1.el5 set to be updated
--> Processing Dependency: cyrus-sasl >= 2.1.10 for package: 2:postfix-2.8.7-1.el5.i386
--> Processing Dependency: libmysqlclient.so.15 for package: 2:postfix-2.8.7-1.el5.i386
--> Processing Dependency: libldap-2.3.so.0 for package: 2:postfix-2.8.7-1.el5.i386
--> Processing Dependency: libdb-4.3.so for package: 2:postfix-2.8.7-1.el5.i386
--> Processing Dependency: libmysqlclient.so.15(libmysqlclient_15) for package: 2:postfix-2.8.7-1.el5.i386
--> Processing Dependency: libssl.so.6 for package: 2:postfix-2.8.7-1.el5.i386
--> Processing Dependency: libcrypto.so.6 for package: 2:postfix-2.8.7-1.el5.i386
--> Processing Dependency: postgresql-libs for package: 2:postfix-2.8.7-1.el5.i386
--> Processing Dependency: libpq.so.4 for package: 2:postfix-2.8.7-1.el5.i386
--> Processing Dependency: liblber-2.3.so.0 for package: 2:postfix-2.8.7-1.el5.i386
--> Running transaction check
---> Package compat-db43.i686 0:4.3.29-15.el6 set to be updated
---> Package compat-openldap.i686 0:2.4.19_2.3.43-15.el6_0.2 set to be updated
---> Package cyrus-sasl.i686 0:2.1.23-8.el6 set to be updated
---> Package openssl098e.i686 0:0.9.8e-17.el6.centos set to be updated
---> Package postfix.i386 2:2.8.7-1.el5 set to be updated
--> Processing Dependency: libmysqlclient.so.15 for package: 2:postfix-2.8.7-1.el5.i386
--> Processing Dependency: libmysqlclient.so.15(libmysqlclient_15) for package: 2:postfix-2.8.7-1.el5.i386
--> Processing Dependency: libpq.so.4 for package: 2:postfix-2.8.7-1.el5.i386
---> Package postgresql-libs.i686 0:8.4.7-1.el6_0.1 set to be updated
--> Finished Dependency Resolution
Error: Package: 2:postfix-2.8.7-1.el5.i386 (CentALT)
Requires: libmysqlclient.so.15(libmysqlclient_15)
Available: mysql-libs-5.0.92-1.el5.i386 (CentALT)
libmysqlclient.so.15(libmysqlclient_15)
Error: Package: 2:postfix-2.8.7-1.el5.i386 (CentALT)
Requires: libmysqlclient.so.15
Available: mysql-libs-5.0.92-1.el5.i386 (CentALT)
libmysqlclient.so.15
Error: Package: 2:postfix-2.8.7-1.el5.i386 (CentALT)
Requires: libpq.so.4
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
[root@localhost ~]# yum install libmysqlclient.so.15
Loaded plugins: fastestmirror, presto
Loading mirror speeds from cached hostfile
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package mysql-libs.i386 0:5.0.92-1.el5 set to be updated
--> Processing Dependency: libssl.so.6 for package: mysql-libs-5.0.92-1.el5.i386
--> Processing Dependency: libcrypto.so.6 for package: mysql-libs-5.0.92-1.el5.i386
--> Running transaction check
---> Package openssl098e.i686 0:0.9.8e-17.el6.centos set to be updated
--> Finished Dependency Resolution
Dependencies Resolved
========================================================================================================================================================================
Package Arch Version Repository Size
========================================================================================================================================================================
Installing:
mysql-libs i386 5.0.92-1.el5 CentALT 1.8 M
Installing for dependencies:
openssl098e i686 0.9.8e-17.el6.centos base 773 k
Transaction Summary
========================================================================================================================================================================
Install 2 Package(s)
Upgrade 0 Package(s)
Total size: 2.6 M
Installed size: 6.5 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
libmysqlclient.so.16 is needed by (installed) mysql-5.1.52-1.el6_0.1.i686
libmysqlclient.so.16 is needed by (installed) perl-DBD-MySQL-4.013-3.el6.i686
libmysqlclient.so.16 is needed by (installed) mysql-server-5.1.52-1.el6_0.1.i686
libmysqlclient.so.16 is needed by (installed) php-mysql-5.3.2-6.el6_0.1.i686
libmysqlclient.so.16(libmysqlclient_16) is needed by (installed) mysql-5.1.52-1.el6_0.1.i686
libmysqlclient.so.16(libmysqlclient_16) is needed by (installed) perl-DBD-MySQL-4.013-3.el6.i686
libmysqlclient.so.16(libmysqlclient_16) is needed by (installed) mysql-server-5.1.52-1.el6_0.1.i686
libmysqlclient.so.16(libmysqlclient_16) is needed by (installed) php-mysql-5.3.2-6.el6_0.1.i686
libmysqlclient_r.so.16 is needed by (installed) mysql-5.1.52-1.el6_0.1.i686
libmysqlclient_r.so.16 is needed by (installed) mysql-server-5.1.52-1.el6_0.1.i686
libmysqlclient_r.so.16(libmysqlclient_16) is needed by (installed) mysql-5.1.52-1.el6_0.1.i686
libmysqlclient_r.so.16(libmysqlclient_16) is needed by (installed) mysql-server-5.1.52-1.el6_0.1.i686
mysql-libs = 5.1.52-1.el6_0.1 is needed by (installed) mysql-5.1.52-1.el6_0.1.i686
Please report this error in [url]http://bugs.centos.org/set_project.php?project_id=16&ref=http://bugs.centos.org/bug_report_page.php?category=yum[/url]
You could try running: rpm -Va --nofiles --nodigestПрошу обратить внимание на ошибку:
Downloading Packages:
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
libmysqlclient.so.16 is needed by (installed) mysql-5.1.52-1.el6_0.1.i686
libmysqlclient.so.16 is needed by (installed) perl-DBD-MySQL-4.013-3.el6.i686
libmysqlclient.so.16 is needed by (installed) mysql-server-5.1.52-1.el6_0.1.i686
libmysqlclient.so.16 is needed by (installed) php-mysql-5.3.2-6.el6_0.1.i686
libmysqlclient.so.16(libmysqlclient_16) is needed by (installed) mysql-5.1.52-1.el6_0.1.i686
libmysqlclient.so.16(libmysqlclient_16) is needed by (installed) perl-DBD-MySQL-4.013-3.el6.i686
libmysqlclient.so.16(libmysqlclient_16) is needed by (installed) mysql-server-5.1.52-1.el6_0.1.i686
libmysqlclient.so.16(libmysqlclient_16) is needed by (installed) php-mysql-5.3.2-6.el6_0.1.i686
libmysqlclient_r.so.16 is needed by (installed) mysql-5.1.52-1.el6_0.1.i686
libmysqlclient_r.so.16 is needed by (installed) mysql-server-5.1.52-1.el6_0.1.i686
libmysqlclient_r.so.16(libmysqlclient_16) is needed by (installed) mysql-5.1.52-1.el6_0.1.i686
libmysqlclient_r.so.16(libmysqlclient_16) is needed by (installed) mysql-server-5.1.52-1.el6_0.1.i686
mysql-libs = 5.1.52-1.el6_0.1 is needed by (installed) mysql-5.1.52-1.el6_0.1.i686
Please report this error in [url]http://bugs.centos.org/set_project.php?project_id=16&ref=http://bugs.centos.org/bug_report_page.php?category=yum[/url]
You could try running: rpm -Va --nofiles --nodigestНо вот при желании установить эти 2 файла, приходит сообщение что они уже установлены.
В чём дело ? Где туплю ?
