Здраствуйте, поставил по инструкции прозрачный прокси на centos 6.4. Теперь у мну не работает заход через доменное имя сайта (любого) а работает только через ip-адрес сайта. "Невозможно определить ip-адрес по имени узла"  собственно в чем может быть проблема?
http://admins.tk/centos__/squid.html

2

в dns

— Ты кто?
— Часть силы той, что без числа
Творит добро, всему желая зла. © Фауст
riso пишет:

в dns

а поточнее?

4

на сервере ping ya.ru проходит ? если да, то скорее всего дело в закрытом 53 порте, покажи iptables -L и еще, клиент получает настройки dns ?

— Ты кто?
— Часть силы той, что без числа
Творит добро, всему желая зла. © Фауст
riso пишет:

на сервере ping ya.ru проходит ? если да, то скорее всего дело в закрытом 53 порте, покажи iptables -L и еще, клиент получает настройки dns ?

пинг с сервера есть. Клиент получает по dhcp

Chain INPUT (policy DROP)
target     prot opt source               destination         
ACCEPT     all  --  anywhere             anywhere            state RELATED,ESTABLISHED 
ACCEPT     all  --  192.168.32.0/24      anywhere            
ACCEPT     all  --  anywhere             anywhere            
ACCEPT     tcp  --  nlykt.ru             anywhere            state NEW tcp dpt:ssh 
ACCEPT     tcp  --  cli-nw.142.160.helios-nw.ru  anywhere            state NEW tcp dpt:ssh 
ACCEPT     tcp  --  cli-nw.57.163.helios-nw.ru  anywhere            state NEW tcp dpt:ssh 
ACCEPT     tcp  --  cli-nw.221.176.helios-nw.ru  anywhere            state NEW tcp dpt:ssh 
ACCEPT     tcp  --  80.73.72.2           anywhere            state NEW tcp dpt:ssh 
ACCEPT     tcp  --  10.161.52.152        anywhere            state NEW tcp dpt:ssh 
ACCEPT     tcp  --  46.48.153.39         anywhere            state NEW tcp dpt:ssh 
ACCEPT     tcp  --  94.245.160.188       anywhere            state NEW tcp dpt:ssh 
ACCEPT     tcp  --  nlykt.ru             anywhere            state NEW tcp dpt:ircu-2 
ACCEPT     tcp  --  cli-nw.142.160.helios-nw.ru  anywhere            state NEW tcp dpt:ircu-2 
ACCEPT     tcp  --  cli-nw.57.163.helios-nw.ru  anywhere            state NEW tcp dpt:ircu-2 
ACCEPT     tcp  --  cli-nw.221.176.helios-nw.ru  anywhere            state NEW tcp dpt:ircu-2 
ACCEPT     tcp  --  anywhere             anywhere            tcp dpt:ftp 
ACCEPT     tcp  --  anywhere             anywhere            state NEW tcp dpt:ssh 
ACCEPT     tcp  --  anywhere             anywhere            state NEW tcp dpt:squid 

Chain FORWARD (policy DROP)
target     prot opt source               destination         
ACCEPT     all  --  192.168.32.2         anywhere            
ACCEPT     all  --  192.168.32.11        anywhere            
ACCEPT     all  --  192.168.32.12        anywhere            
ACCEPT     all  --  192.168.32.13        anywhere            
ACCEPT     all  --  192.168.32.14        anywhere            
ACCEPT     all  --  192.168.32.15        anywhere            
ACCEPT     all  --  192.168.32.16        anywhere            
ACCEPT     all  --  192.168.32.17        anywhere            
ACCEPT     all  --  192.168.32.18        anywhere            
ACCEPT     all  --  192.168.32.19        anywhere            
ACCEPT     all  --  192.168.32.20        anywhere            
ACCEPT     all  --  192.168.32.21        anywhere            
ACCEPT     all  --  192.168.32.22        anywhere            
ACCEPT     all  --  192.168.32.23        anywhere            
ACCEPT     all  --  192.168.32.24        anywhere            
ACCEPT     all  --  192.168.32.25        anywhere            
ACCEPT     all  --  192.168.32.26        anywhere            
ACCEPT     all  --  192.168.32.27        anywhere            
ACCEPT     all  --  192.168.32.28        anywhere            
ACCEPT     all  --  192.168.32.29        anywhere            
ACCEPT     all  --  192.168.32.30        anywhere            
ACCEPT     all  --  192.168.32.31        anywhere            
ACCEPT     all  --  192.168.32.32        anywhere            
ACCEPT     all  --  192.168.32.33        anywhere            
ACCEPT     all  --  192.168.32.34        anywhere            
ACCEPT     all  --  192.168.32.35        anywhere            
ACCEPT     all  --  192.168.32.36        anywhere            
ACCEPT     all  --  192.168.32.208       anywhere            
GORODSKOY_INET  all  --  192.168.32.0/24      anywhere            
ACCEPT     tcp  --  nlykt.ru             192.168.32.2        state NEW tcp dpt:ms-wbt-server 
ACCEPT     tcp  --  cli-nw.57.163.helios-nw.ru  192.168.32.2        state NEW tcp dpt:ms-wbt-server 
ACCEPT     tcp  --  cli-nw.142.160.helios-nw.ru  192.168.32.2        state NEW tcp dpt:ms-wbt-server 
ACCEPT     tcp  --  cli-nw.221.176.helios-nw.ru  192.168.32.2        state NEW tcp dpt:ms-wbt-server 
ACCEPT     tcp  --  80.73.72.2           192.168.32.2        state NEW tcp dpt:ms-wbt-server 
ACCEPT     tcp  --  10.161.52.152        192.168.32.2        state NEW tcp dpt:ms-wbt-server 
ACCEPT     tcp  --  46.48.153.39         192.168.32.2        state NEW tcp dpt:ms-wbt-server 
ACCEPT     all  --  anywhere             anywhere            state RELATED,ESTABLISHED 
ACCEPT     all  --  192.168.32.217       anywhere            
ACCEPT     all  --  192.168.32.129       anywhere            
ACCEPT     all  --  192.168.32.207       anywhere            
ACCEPT     all  --  192.168.0.1          anywhere            
ACCEPT     all  --  192.168.32.216       anywhere            
ACCEPT     all  --  192.168.32.218       anywhere            
ACCEPT     all  --  192.168.32.2         anywhere            
ACCEPT     all  --  192.168.32.201       anywhere            
ACCEPT     all  --  192.168.32.226       anywhere            
ACCEPT     all  --  192.168.32.220       anywhere            
ACCEPT     all  --  192.168.32.224       anywhere            
ACCEPT     all  --  192.168.32.223       anywhere            
ACCEPT     all  --  192.168.32.205       anywhere            
ACCEPT     all  --  192.168.32.227       anywhere            
ACCEPT     all  --  192.168.32.222       anywhere            
ACCEPT     all  --  192.168.32.226       anywhere            
ACCEPT     all  --  192.168.32.221       anywhere            
ACCEPT     all  --  192.168.32.217       anywhere            
ACCEPT     all  --  192.168.32.135       anywhere            
ACCEPT     all  --  192.168.32.136       anywhere            
ACCEPT     all  --  192.168.32.134       anywhere            
ACCEPT     all  --  192.168.32.236       anywhere            
ACCEPT     all  --  192.168.32.237       anywhere            
ACCEPT     all  --  192.168.32.203       anywhere            
ACCEPT     all  --  192.168.32.234       anywhere            
ACCEPT     all  --  192.168.32.239       anywhere            
ACCEPT     all  --  192.168.32.238       anywhere            
ACCEPT     all  --  192.168.32.233       anywhere            
ACCEPT     all  --  192.168.32.202       anywhere            
ACCEPT     all  --  192.168.32.137       anywhere            
ACCEPT     all  --  192.168.32.235       anywhere            
ACCEPT     all  --  192.168.32.232       anywhere            
ACCEPT     all  --  192.168.32.233       anywhere            
ACCEPT     all  --  192.168.32.234       anywhere            
ACCEPT     all  --  192.168.32.139       anywhere            
ACCEPT     all  --  192.168.32.140       anywhere            
ACCEPT     all  --  192.168.32.136       anywhere            
ACCEPT     all  --  192.168.32.143       anywhere            
ACCEPT     all  --  192.168.32.144       anywhere            
ACCEPT     all  --  192.168.32.145       anywhere            
ACCEPT     all  --  192.168.32.141       anywhere            
ACCEPT     all  --  192.168.32.152       anywhere            
ACCEPT     all  --  192.168.32.153       anywhere            
ACCEPT     all  --  192.168.32.155       anywhere            

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination         

Chain GORODSKOY_INET (1 references)
target     prot opt source               destination         
ACCEPT     all  --  anywhere             10.144.65.0/24      
ACCEPT     all  --  anywhere             10.160.0.0/11       
ACCEPT     all  --  anywhere             213.129.32.0/19     
ACCEPT     all  --  anywhere             213.129.61.0/24     
ACCEPT     all  --  anywhere             213.129.62.0/24     
ACCEPT     all  --  anywhere             213.129.63.0/24     
ACCEPT     all  --  anywhere             46.48.128.0/17      
ACCEPT     all  --  anywhere             80.73.64.0/19       
ACCEPT     all  --  anywhere             80.73.80.0/24       
ACCEPT     all  --  anywhere             89.113.40.0/21      
ACCEPT     all  --  anywhere             91.185.224.0/19     
ACCEPT     all  --  anywhere             94.245.128.0/18     
ACCEPT     all  --  anywhere             95.167.48.0/24      
ACCEPT     all  --  anywhere             10.4.1.0/24         
ACCEPT     all  --  anywhere             109.197.200.0/21    
ACCEPT     all  --  anywhere             128-74-248-0.broadband.corbina.ru/22 
ACCEPT     all  --  anywhere             77.242.0.0/21       
ACCEPT     all  --  anywhere             77.242.4.16/30      
ACCEPT     all  --  anywhere             host-78-31-222-24.esotel.ru/30 
ACCEPT     all  --  anywhere             79.133.86.128/25    
ACCEPT     all  --  anywhere             80.72.29.96/27      
ACCEPT     all  --  anywhere             80.81.216.0/24      
ACCEPT     all  --  anywhere             82.179.48.0/21      
ACCEPT     all  --  anywhere             84.237.104.0/21     
ACCEPT     all  --  anywhere             87.226.235.0/24     
ACCEPT     all  --  anywhere             87.226.236.0/24     
ACCEPT     all  --  anywhere             88.82.160.0/19      
ACCEPT     all  --  anywhere             88.82.168.0/23      
ACCEPT     all  --  anywhere             91.193.176.0/22     
ACCEPT     all  --  anywhere             91.211.76.0/22      
ACCEPT     all  --  anywhere             94.231.16.0/20      
ACCEPT     all  --  anywhere             95-31-112-0.broadband.corbina.ru/24

6

лень разбираться во всей этой каше, поэтому скажу проще: установи dnsmasq, и отдавай клиентам в dns адрес сервера. Но скорее всего все проще и iptables мешает выйти на гугловские dns (судя по статье установлены именно они).

— Ты кто?
— Часть силы той, что без числа
Творит добро, всему желая зла. © Фауст

7

Покажите но сам конфиг сквида

Trouble  in WINDOWS reboot, trouble in UNIX be root.
kisil пишет:

Покажите но сам конфиг сквида

#
# Recommended minimum configuration:
#
acl manager proto cache_object
acl localhost src 127.0.0.1/32 ::1
acl to_localhost dst 127.0.0.0/8 0.0.0.0/32 ::1

# Example rule allowing access from your local networks.
# Adapt to list your (internal) IP networks from where browsing
# should be allowed
acl our_networks src 192.168.32.0/24
acl localnet src 10.0.0.0/8    # RFC1918 possible internal network
acl localnet src 172.16.0.0/12    # RFC1918 possible internal network
acl localnet src 192.168.0.0/16    # RFC1918 possible internal network
acl localnet src fc00::/7       # RFC 4193 local private network range
acl localnet src fe80::/10      # RFC 4291 link-local (directly plugged) machines

acl SSL_ports port 443
acl Safe_ports port 80        # http
acl Safe_ports port 21        # ftp
acl Safe_ports port 443        # https
acl Safe_ports port 70        # gopher
acl Safe_ports port 210        # wais
acl Safe_ports port 1025-65535    # unregistered ports
acl Safe_ports port 280        # http-mgmt
acl Safe_ports port 488        # gss-http
acl Safe_ports port 591        # filemaker
acl Safe_ports port 777        # multiling http
acl CONNECT method CONNECT

#
# Recommended minimum Access Permission configuration:
#
# Only allow cachemgr access from localhost
http_access allow manager localhost
http_access deny manager

# Deny requests to certain unsafe ports
http_access deny !Safe_ports

# Deny CONNECT to other than secure SSL ports
http_access deny CONNECT !SSL_ports

# We strongly recommend the following be uncommented to protect innocent
# web applications running on the proxy server who think the only
# one who can access services on "localhost" is a local user
#http_access deny to_localhost

#
# INSERT YOUR OWN RULE(S) HERE TO ALLOW ACCESS FROM YOUR CLIENTS
#

# Example rule allowing access from your local networks.
# Adapt localnet in the ACL section to list your (internal) IP networks
# from where browsing should be allowed
http_access allow localnet
http_access allow localhost
http_access allow our_networks

# And finally deny all other access to this proxy
http_access deny all

# Squid normally listens to port 3128
http_port 3128 intercept

# We recommend you to use at least the following line.
hierarchy_stoplist cgi-bin ?

# Uncomment and adjust the following to add a disk cache directory.
#cache_dir ufs /var/spool/squid 100 16 256

# Leave coredumps in the first cache dir
coredump_dir /var/spool/squid

# Add any of your own refresh_pattern entries above these.
refresh_pattern ^ftp:        1440    20%    10080
refresh_pattern ^gopher:    1440    0%    1440
refresh_pattern -i (/cgi-bin/|\?) 0    0%    0
refresh_pattern .        0    20%    4320
visible_hostname gate.adgezia

9

burutarunootoko,
Пожалуйста, пользуйтесь тегами оформления сообщений.

10

TC ищите в ввашем конфиге настройки  DNS OPTIONS. А именно вот такую директиву

dns_nameservers

и прописывайте ДНС прова. Вот пример
У вас не прописан ДНС сервер к которому должен обращаться кальмар. Хотя без правильных настроек ДНС сквид не должен даже запускаться.

Trouble  in WINDOWS reboot, trouble in UNIX be root.